Page MenuHome

Mesh deform modifier doesn't work after editing mesh object to deform with
Closed, InvalidPublic

Description

System Information
Operating system: Ubuntu 18.04
Graphics card: AMD Radeon 580RX

Blender Version
Broken: 2.80 (sub 55), branch: master, commit date: 2019-04-10 15:33, hash: a3b88c917299

Exact steps for others to reproduce the error

  1. Create plane object.
  2. Extrude vertices so it looks like cube.
  3. Bind it as "mesh object to deform with". It works.
  4. Unbind.
  5. Remove extruded vertices so it looks like plane again.
  6. Extrude vertices again so it looks like cube again.
  7. Bind it as "mesh object to deform with" again. It doesn't work.

Here are video how to reproduce bug and blend file


Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) closed this task as Invalid.
Sebastian Parborg (zeddb) claimed this task.

The issue is that the normals of the deform cage is not good.

You can see it in your example file if you activate the face orientation overlay. The mesh normals has to point outward so that the cage forms a valid volume.