Page MenuHome

Show parenting hierarchy in outliner view layer view
Closed, ResolvedPublic

Description

Currently we don't show parenting hierarchy in the outliner when in the view layer view. The reason is that children may be in different collections, which makes things confusing.

  • If parent and child is in the same collection we just show the hierarchy as usual.
  • If a parent has children that are not in the same collection, they are shown below but greyed out and not showing restriction icons toggles. A tooltip can explain the meaning of this.
  • The child still appears in the collection it is part of without the parent.

Details

Type
To Do

Event Timeline

Brecht Van Lommel (brecht) triaged this task as Confirmed, High priority.
Brecht Van Lommel (brecht) renamed this task from Show parenting hierarchy in outline view layer view to Show parenting hierarchy in outliner view layer view.

I seems, you are talking about cumulativeness - ability to assign same object to different hirarchical levels?
Yes, it causes some problems

There were talks about "pickwalking" behavoiur
https://devtalk.blender.org/t/layers-maniphest/6578/22?u=1d_inc

We also made special tool, called "Isolate layers" for 2.79, that isolates QCD slots of selected objects, including cumulativity effect - it isolates all layers object belongs to.
It was pretty much enough for work with complex cumulative structures in 20 layers.
Well, greying is interesting idea, but it will not take much effect if almost everything in scene is in different collections cumulatively.

@Dalai Felinto (dfelinto), I guess this task can be marked as resolved?

Dalai Felinto (dfelinto) closed this task as Resolved.Wed, Apr 24, 5:33 PM

RIght. There seems to be a bug spotted by @Sebastian Koenig (sebastian_k). But all in all this is implemented, yes.