Page MenuHome

Grease Pencil: Add Onion Skin Toggle Buttons in Dope Sheet Summary?
Closed, ArchivedPublic

Description

I know that the onion skin toggles can be found in the layers panel. But it is such a pain to have to go to it everytime I'm working with the Dope Sheet.
Wouldn't it be easier if you also put those in the Dope sheet for grease pencil?

Details

Type
Design

Event Timeline

+1
Moving my eyes all around isn't very efficient. This would also mean you could animate without the inspector at all.

+1

Complained about the same thing to the blender.chat #ui yesterday.

If you have more than 1 grease pencils, sooner or later a layer's onion skin, other than your active(working on) grease pencil will end up in the way.
You have to go to object mode -> select the other object(GP)->go to properties-> layers -> turn off onion skinning -> go to object mode ->select your work grease pencil again-> go t draw mode and get back to work.

As I said in the chat....I might be the odd person...but it's too many steps to turn a toggle on and off. Especially when it's an often used toggle.

Antonio Vazquez (antoniov) closed this task as Archived.
Antonio Vazquez (antoniov) claimed this task.

I understand your request and agree 100%, but currently the dopesheet is not ready to add a new button and needs a change to support it.

As we are now in 2.80 beta UI freeze period, we cannot change this, but we add it to ToDo list (we have limited resources and need to define priorities).

As this si not a bug, but a feature request, I'm going to archive it.

+1
Complained about the same thing to the blender.chat #ui yesterday.
If you have more than 1 grease pencils, sooner or later a layer's onion skin, other than your active(working on) grease pencil will end up in the way.
You have to go to object mode -> select the other object(GP)->go to properties-> layers -> turn off onion skinning -> go to object mode ->select your work grease pencil again-> go t draw mode and get back to work.
As I said in the chat....I might be the odd person...but it's too many steps to turn a toggle on and off. Especially when it's an often used toggle.

Perhaps since the ui freeze has taken place. Maybe a simple python add-on can be a temporary fix; idk what that wud be though

@Randell Acuram (Ranakade) hmm...good point. I'll look in to it.

Yeah I managed to make a simple script that will toggle the onion skinning for the selected layer(layers).
I'll work on making a ui button later tonight

@Randell Acuram (Ranakade) Tada!!!
https://github.com/okuma10/Grease-Nudge/blob/master/OnionSkinToggle.py
the only problem is that I don't know why I get 3 duplicate buttons.

Wuuut, dang I didnt think you could whip a plugin up that quickly (Cuz i honestly have no clue about python) I'll definitely check this out today :-)