Page MenuHome

CTRL for InvertSnapping (feels like) Is HardCoded Somewhere
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-7-6.1.7601-SP1 64 Bits
Graphics card: GeForce GTX 1060 6GB/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 417.35

Blender Version
Broken: version: 2.80.0-git.860a9f979d60-windows64
Worked: I don't think I had this working (like 2.7x) ever

Short description of error
This is going to be hard to assure you guys that this is really a thing.

Basically SNAPPING (to be precise Invert Snapping) is hardcoded somewhere with CTRL.

I use a customized blender version, where I have CTRL+TWEAK LMB set for "Move" (transform.translate).
The behavior I get is: as soon as I enter "Move Mode" my snapping is INVERTED (this is totally undesired).
I went and Disabled/Unchecked all of the SNAPPING entries from the KEYMAP, and as expected all snapping is off now. But I still get the same thing when I invoke "Move Mode" with CTRL+TWEAK LMB, the snapping gets inverted!

Checked with FactoryDefault and I get the same thing.

What I will do is give you 2 setups you can test this with pretty fast.

  • First one is going to have the "Move" (transform.translate) bound to CTRL+TWEAK LMB. Everything else is going to be FactoryDefault
  • Second one is going to be like the first one, but I will also disable all SNAPPING bound to CTRL. So you can see that snappings are disabled, yet I still get "InvertSnapping" when invoking "MoveMode' using CTRL+TWEAK LMB.

Exact steps for others to reproduce the error

  • Install the 1st BlenderPrefs and with the Default Cube selected, press CTRL + TWEAK + LMB. You will see that Snapping will get Enabled, even though it was Disabled prior to that. You can then toggle it by Releasing CTRL (but this is a major inconvenience to get around the initial bug). And by pressing CTRL again you can toggle it again, You are in MoveMode this whole time!
  • Now install the 2nd BlenderPrefs. And again with the Default Cube selected, press CTRL + TWEAK + LMB. As before, you will see that Snapping will get Enabled, even though it was Disabled prior to that. But this time you won't be able to toggle it, because all CTRL hotkeys for SNAPPING have been unchecked in the Keymap. This is to show that the initial SnappingToggle that happend is not in the Keymap entries (at least I can't find it). And while were at it, maybe the reason I can not find it is that the Modals don't show in keymap Search filters! Maybe that's something that could be addressed as well?

This is where you can grab the 2 BlendPrefs settings to test this out:
http://edge-loop.com/images/blender/bugtracker/Blender_280_CTRL_Snapping_Bug_TestingPreferences.zip

That is basically just the 2.80 folder from "C:\Users\...........\AppData\Roaming\Blender Foundation\Blender" that you need to place there in order to test the bug.

Thanks again to anyone looking into this!

Event Timeline

Sebastian Parborg (zeddb) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.

Right, seems to be hard coded in blender/editors/transform/transform.c:2412.

@William Reynish (billreynish) I'm unsure if we can easily move this out to the keymap. Any input etc?

Brecht Van Lommel (brecht) reopened this task as Open.EditedApr 16 2019, 3:46 PM

I didn't actually test this, just noticed the bug in not ignoring disabled keymap items and fixed that. There may be another issue here, can someone test?

Brecht,

I'm kind of deep into this, that's why I was able to catch this. Once I get the buildbot with the fix, I'll run it through tests with my setup. I can report back here, if it's OK with you.

Thanks again guys for looking into this!!! This was a major roadblock with a custom setup that is similar to something I use.
Appreciate it!!!

Tested with 5d8030b8f3cf works well now!
Thanks Brecht, much appreciated!!

Sebastian Parborg (zeddb) closed this task as Resolved.Apr 17 2019, 4:29 PM