Page MenuHome

GPU + CPU crashing regularly
Closed, InvalidPublic

Description

System Information
Operating system: Windows-10-10.0.17134 64 Bits
Graphics card: GeForce GTX 850M/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 419.67

Blender Version
Broken: version: 2.80 (sub 54), branch: blender2.7, commit date: 2019-04-07 15:02, hash: rB75f551facaf0
Worked: (optional)

Short description of error
I am using that new feature in blender that combines GPU and CPU rendering but it quite crashing after a period of time in big scenes that require quite a time to render them and it really frustrating me that it crashes after like 2 hours of rendering and not continue, on the other hand when I use GPU or CPU render as regularly it works fine but much bigger time to render.

Exact steps for others to reproduce the error
1- enable gpu and cpu rendering
2- click render on an intense scene
3- wait for it!!

Details

Type
Bug

Event Timeline

I was able to reproduce the crash with this .blend file on a laptop with a GTX 860M which is almost the same as the submitter's machine, using yesterday's buildbot version of 2.80. Maybe it's just running out of memory on the GPU? Does your 850M have 2GB of memory, or 4GB? Mine is a 2GB 860M. Haven't tried on more modern hardware. I'll go see what the GTX 1060 thinks of it.

Crash output:

Read prefs: C:\Users\Gavin\AppData\Roaming\Blender Foundation\Blender\2.80\config\userpref.blend
found bundled python: C:\Users\Gavin\Desktop\blender-2.80.0-git.db80d5c560f5-windows64\2.80\python
Read blend: C:\Users\Gavin\Desktop\Blender\ps4stick original.blend
CUDA error: Illegal address in cuCtxSynchronize(), line 1545

Refer to the Cycles GPU rendering documentation for possible solutions:
https://docs.blender.org/manual/en/dev/render/cycles/gpu_rendering.html

CUDA error: Illegal address in mem_alloc_result, line 850
CUDA error: Illegal address in cuMemsetD8(cuda_device_ptr(mem.device_pointer), 0, mem.memory_size()), line 986
CUDA error: Illegal address in cuMemsetD8(cuda_device_ptr(mem.device_pointer), 0, mem.memory_size()), line 986
CUDA error: Illegal address in cuModuleGetFunction(&cuFinalize, cuFilterModule, "kernel_cuda_filter_finalize"), line 1472
Error : EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FFDCEB4BC4F
Module : C:\WINDOWS\SYSTEM32\nvcuda.dll

The 1060 chewed through it in 9 minutes with no errors. I note that in GPU+CPU mode, Cycles is using substantially more GPU memory than in GPU only mode. My guess would be that this scene is simply exceeding the GPU resources available in the old GTX 850M (probably 2GB of dedicated GPU memory) when Cycles is in CPU+GPU mode.

I was able to get the render to complete successfully in 24 minutes on the 860M in GPU+CPU by changing the tile size from 256x256 to 16x16. Modern Cycles no longer requires large render tiles and small tiles are often faster even without using CPU+GPU (where they are much faster because the GPU will be able to do much more of the work at the end of the render rather than waiting for a lot of slow CPU tiles to complete).

Ok thanks a lot for all your hard work I'll try that out... and yeah mine is 2GB also..thanks again

Adam Preisler (Alphisto) closed this task as Invalid.
Adam Preisler (Alphisto) claimed this task.

Closing this as invalid because it related to hardware limitations and render settings issue.

@Abdelrahman Amr (abdo25) if you have any news, feel free to reopen