Page MenuHome

Setting camera position changes object's transform
Closed, InvalidPublic

Description

System Information
Operating system: W10
Graphics card: 980Ti

Blender Version
Broken: 2.80 19-04-17 19.26

Short description of error
Using ctrl+alt+num0 to set up camera causes selected object (not camera) to be transformed. And if I select camera, it still transforms the object. I can see camera bounds set, but camera object is still in original place.

Exact steps for others to reproduce the error
.blend is saved in a state when you just have to set up camera, and you'll notice the only plane added is transformed.
I've noticed this bug in a couple of other projects but couldn't understand what(when) this was happening. Sometimes it happens just when I 'enter' camera (num0).


Details

Type
Bug

Event Timeline

Additional comment:
After deleting the plane and trying to set camera view - nothing happens.
However, when I shift-C - it starts working again, so I guess shift-C is a part of this bug.

Sebastian Parborg (zeddb) closed this task as Invalid.
Sebastian Parborg (zeddb) claimed this task.

This is because you have the plane object set as camera:

@Sebastian Parborg (zeddb) well then other question, how do one even do this? You can't pick plane from camera list, you can't use eyedropper to place it there, you can't type it there by hand (it won't be accepted)?

You do it with the Set Active Object as Camera shortcut (Ctrl Numpad 0)