Page MenuHome

b2.8 3d cursor wrong alignment by normal
Open, Confirmed, LowPublic

Description

System Information
Operating system: Windows 10 pro
Graphics card: nvidia gtx 1080

Blender Version
version: 2.80 (sub 57), branch: master, commit date: 2019-04-16 06:07, hash: edc1b0167518, type: Release
build date: 15/04/2019, 23:25

Problem

Hi, i've noticed problem with 3d cursor alignment. If we are working under object mode and want align our 3d cursor by object surface, orientation it totally wrong.

I've find way get around this problem, waht we need to do:

  • 1. For first we must dive into edit object mode,
  • 2. then selected one element of object 'Face, Edge or Vertices'
  • 3. switch on 'transform orientation' on 'Normal'.
  • 4. turn on our move 'GIZMO'
  • 5. and for now if we to align 3d cursor with snaping by any area of model, we will get correct 3d cursor orientation by normals

I recorder short video with it and attached few screenshots.

https://youtu.be/OVSkBEQDgX0

Event Timeline

Jacques Lucke (JacquesLucke) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Apr 23 2019, 1:01 PM

Shouldn't you use Orientation: Geometry instead of Transform in the 3D cursor tool settings?

Shouldn't you use Orientation: Geometry instead of Transform in the 3D cursor tool settings?

Nope, it's doesn't matter what mode of 3d cursor are you using, under object mode it's doesn't work

Jacques Lucke (JacquesLucke) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Apr 23 2019, 3:26 PM
Adam Preisler (Alphisto) closed this task as Resolved.May 1 2019, 3:13 PM
Adam Preisler (Alphisto) claimed this task.

Closing this as resolved because the issue is gone in 2.80.60

You need to set Orientation: Geometry as @Jacques Lucke (JacquesLucke) noted



Closing this as resolved because the issue is gone in 2.80.60
You need to set Orientation: Geometry as @Jacques Lucke (JacquesLucke) noted



This is problem still here. Just try apply transform after rotation and then aling you 3d cursor to surface.

Adam Preisler (Alphisto) lowered the priority of this task from Needs Triage by Developer to Confirmed, Low.Sep 18 2019, 12:39 PM

Can confirm that cursor doesn't respect quad orientation on randomly rotated mesh that has applied rotation.

The normal is correct however it's rotation along it's axis is seemingly random although it's the same angle for the same planes.

Correct behavior would be to copy rotation of the underlying meshes' normal.


Check T69603 for further information when it comes to Edit Mode / Snap Cursor to Selected. These problems are highly likely linked.

Working on a patch to get the 3dcursor in line with the editmode face transform gizmo...