Page MenuHome

Reflection anomaly when using Normal Map on Eevee
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.17134 64 Bits
Graphics card: GeForce GTX 970/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 416.34

Blender Version
Broken: version: 2.80 (sub 60), branch: blender2.7, commit date: 2019-05-01 16:58, hash: rBa372e5e426e4
Worked: (optional)

Short description of error
[Please fill out a short description of the error here]
I have an Eevee scene where the floors are using a normal map. I've found that the reflections are distorted/twisted depending on the normal map strength value. It is most evident when using a relatively smooth/shiny surface, and particularly so because I have area lights in the windows.

Exact steps for others to reproduce the error
[Please describe the exact steps needed to reproduce the issue]
I've reproduced the problem in a simple scene with a plane for the floor, and an area light. I will supply two copies of the blend file, one with embedded textures (CC0) from Texture Haven. The other scene which demonstrates the problem best, requires a free file to be downloaded from Poliigon.
To demonstrate the problem, simply modify the normal map strength - by selecting and dragging left/right with the mouse.

[Based on the default startup or an attached .blend file (as simple as possible)]
This file has embedded Texture Haven images textures (downloaded from https://texturehaven.com/tex/?c=wood&t=brown_planks_09).


This file is the one which requires a Poliigon normal map texture. The file can be downloaded from here for free (https://www.poliigon.com/texture/wood-flooring-044), and works best with a PNG, but I don't think the resolution is important.

When you load either file, you will need to switch to rendered view. The Plane object should be selected. Modify/drag the Normal Map strength in the Shader Editor window.

I've uploaded some videos and screen shots which show the problem to Google Photos.
https://photos.app.goo.gl/257E7pyCUkXrnpnu7

  • Item 1: Animation, Eevee 2.80, Normal Map Non-Color Data, Strength 0-2.mp4

Rendered in Eevee with normal map strength being modified from 0 to 2.
Eevee 2.80 Strength=0

Eevee 2.80 Strength=1

  • Item 2: Animation, Cycles 2.80, Normal Map Non-Color Data, Strength 0-2.mp4

The same as item 1, but rendered with Cycles in 2.80. As you can see there is no distortion of the light, and the surface bump simply gets stronger.
Cycles 2.80 Strength=0

Cycles 2.80 Strength=1

  • Item 3: Animation, Cycles 2.80, Normal Map Color Data, Strength 0-2.mp4

Here I found a weird anomaly where if I erroneously set the image texture to Color Data (instead of Non-Color Data), then when I render with Cycles in 2.80 I get the same effect as I observed in Eevee.

  • Item 4: Animation, Cycles 2.79, Normal Map Color Data, Strength 0-2.mp4

This is the same as item 3, but rendered in Cycles with 2.79b. When using Color Data, you get the same distortion.

  • Item 5: Animation, Eevee 2.80, Normal Map Color Data, Strength 0-2.mp4

This is the same as item 3, but now rendered in Eevee. I think the distortion was more pronounced than when using Non-Color Data.

  • Item 6: Kitchen Living Movie 1.mkv

This was the actual scene rendered in Eevee 2.80 where I observed the problem. Around 12 seconds in, you can see this weird diagonal line across the floor. This is actually the reflection of the window.

  • Item 7: Fly-through reflection problem.png

This is a screen capture from the fly-through video in Item 6.

  • Item 8: Sitting room scene with combing artefacts due to normal map.png

This is another room in the actual scene once again rendered in Eevee 2.80. I've highlighted a section on the floor where there is a secondary problem evident. Specifically if you view at 100% you can a series of lines which look like the combing effect you can get with interlaced video. These lines are actually the reflection of the wall/window in the floorboards.

  • Item 9: Sitting room scene with with normal map deactivated.png

This is the same scene as Item 8. The only difference here is that the normal map strength has been set to 0 (was 1). You can now clearly see the reflections of the windows, walls and mantelpiece, and the reflections are vertically below, not distorted to the side.

Thank you for your help.
Mark

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Confirmed, Medium priority.
Clément Foucault (fclem) closed this task as Resolved.May 31 2019, 1:39 PM

I think this was a duplicate of normal map color management discrepancy between cycles and eevee. Should work now.

Confirming that the problem is indeed fixed. Thanks for resolving this.

These images are using Eevee, with the normal strength set to 1.
Image 1: Kitchen/Living


Image 2: Sitting