Page MenuHome

Pole target of IK bone constraint not working.
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.17134 64 Bits
Graphics card: GeForce GTX 1060 6GB/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 419.17

Blender Version
Broken: version: 2.80 (sub 60), branch: blender2.7, commit date: 2019-05-03 21:09, hash: rBee0d8426ab6d
the most recent build ('2e582f8ab53c') has also this issue

Short description of error


adding pole target to IK constraint makes IK bones not bending. Its hard to explain what I mean so please open the file.

Exact steps for others to reproduce the error

  1. Open the file
  2. Move the 'IK CTRL' bone
  3. Notice how bones aren't bending to the pole target as expected.
  4. remove the Pole target form the constraint and Notice how Ik works without pole target

Details

Type
Bug

Event Timeline

When using Pole target, bones must have a little initial rotation in it's blending detection. Your IK chain is currently a straight line, which confuses the IK as to how it should bend in the first place.

so it is not a bug that pole target is not working when bones have no initial rotation?

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

That's correct, the bones must have an initial rotation, also for IK it's much more reliable if you give a hint which direction the bones should rotate.