Page MenuHome

Weighted Normal modifer treat Bevel Weighted edge also as a Sharp Edge when "Keep sharp" edge is turned ON
Closed, InvalidPublic

Description

System Information
Operating system: Windows-10-10.0.17134 64 Bits
Graphics card: GeForce GTX 1060 6GB/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 419.67

Blender Version
Broken: version: 2.80 (sub 53), branch: blender2.7, commit date: 2019-03-31 21:52, hash: rBb936d7b16c62
Worked: (optional)

Short description of error
When working in mid-poly workflow using weighted normal it can be an issue.
Sometimes I'm using "Bevel modifer", but sometimes I'm also making bevels by hand.

Picture and Blender file describe the problem better.

Details

Type
Bug

Event Timeline

George Vogiatzis (Gvgeo) triaged this task as Confirmed, Medium priority.

@Howard Trickey (howardt) It looks like all the edges are marked as sharp. Does not matter what was before or set in modifier.
I was blind. These objects, have sharp edges already.
But indeed, the harden option marks edges as sharp.

George Vogiatzis (Gvgeo) claimed this task.

Found the answer in the manual.

Harden Normals
When enabled, the per-vertex face normals of the bevel faces are adjusted to match the surrounding faces, and the normals of the surrounding faces are not affected – so the effect is to keep the surrounding faces flat (if they were before), with the bevel faces shading smoothly into them. For this to work, custom split normals need to be enabled, which requires Auto Smooth to be enabled (see Normals).


The objects had sharp edges, and were missing custom split normals.

Marking the bug as invalid, although I would agree, that is best to add this info in the tooltip.