Page MenuHome

Allow negative frames cant push the start frame negatively
Closed, InvalidPublic

Description

System Information
Operating system: Windows-10-10.0.17134 64 Bits
Graphics card: GeForce GTX 1060 6GB/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 425.31

Blender Version
Broken: version: 2.80 (sub 61), branch: master, commit date: 2019-05-11 18:20, hash: rBebc44aae9897

Short description of error
Even if "allow negative frames" is on in the animation preferences, you cant move the start frame to negative frames

Exact steps for others to reproduce the error
go to preferences > animation
tick on "allow negative frames"
go to the start frame and drag it negatively.
nothing happens.
:(

Details

Type
Bug

Event Timeline

William Reynish (billreynish) closed this task as Invalid.

This is not a bug. Allow Negative Frames makes it so you can set the playhead to negative frames - it doesn't allow setting your output frame range to be in the negative range.

oh i thought we could in 2.79 it turns out we couldn't just drag the start frame negatively, but we can stand on a negative frame and set it as a startframe.

Why did we lose this functionality?

@Luciano Muñoz Sessarego (looch) Both 2.7x and 2.8 seem to have a bug where it allows users to set the start frame to be in the negative range when using the Set Start Frame operator.

Nothing has changed between 2.7 and 2.8 in this respect, but there is an issue, albeit a different one to the one described in this bug report.

yeah and its buggy, in the case of 2.79 it works well
in 2.8 you set it but if you start playing it kind of jumps to whatever weird rame..

@Luciano Muñoz Sessarego (looch) I cannot reproduce any change or regression in 2.8. They both have the same bug, which is that they allow setting the frame range to be negative when using the Set Start Frame operator.