Page MenuHome

Fullscreen Area Button conflicts with Sidebar.
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10 64 Bits
Graphics card: GeForce GTX 1050 Ti latest driver

Blender Version
Broken: version: 2.80.71 hash: 828efef15175
Worked: (optional)

Short description of error
Fullscreen Area Button conflicts with Sidebar top row...this should be fixed before UI freeze, probably best to bring back those arrows in the 2.79b and put them in the bottom right corner.

Exact steps for others to reproduce the error
Toggle fullscreen area in the viewport (Ctrl+alt+space) and try to click in the top right corner in the n-panel location bar.

Event Timeline

There are two bugs, the first one is an invisible icon.

Worked: version: 2.80 (sub 60), branch: blender2.7, commit date: 2019-05-07 19:17, hash: rB3dc9da3a74ee
Broken: version: 2.80 (sub 64), branch: blender2.7, commit date: 2019-05-13 22:40, hash: rBf070bdd7c9c4

The second bug, overlapping, is also present in version 2.79b.

Region Overlap OFFRegion Overlap ON

And it's not a Maximized Area, it's a Fullscreen Area.

Zino Guerr (Zino) added a comment.EditedMay 29 2019, 1:23 AM

@Yevgeny Makarov (jenkm), the operators are called that way "Maximized Area" which has this bug. ..i found it in the UI and the tooltip calls it both fullscreen and Maximized ;)

Sebastian Parborg (zeddb) closed this task as Resolved.
Sebastian Parborg (zeddb) claimed this task.

This seems to be fixed. At least I can't seem to reproduce this with the latest build.

This seems to be fixed. At least I can't seem to reproduce this with the latest build.

the overlap still happens, so not sure how it's fixed!!

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

The you will have to provide some nice step by step guide to reproduce this.

Simply maximizing the 3D viewport and clicking in the areas pointed out above is not working for me.

@Sebastian Parborg (zeddb) check out my comment above, this refers to a Fullscreen Area not a Maximized Area. There is no close button in the maximized area, only in the fullscreen.

Sebastian Parborg (zeddb) renamed this task from Maximized Area Button conflicts with Sidebar. to Fullscreen Area Button conflicts with Sidebar..
Sebastian Parborg (zeddb) raised the priority of this task from Needs Information from User to Confirmed, Medium.

I also noticed that if you disable this:

it does not help, since it deactivates the button function but the button itself remains (continues to block other items).