Page MenuHome

Blender on Ubuntu misinterprets keyboard and mouse input after a resource-intensive task
Closed, ArchivedPublic

Description

System Information
Operating system: Ubuntu Linux. Versions 16.04 and 18.04
Graphics card: irrelevant (happened on multiple systems, with both NVIDIA or integrated INTEL graphics)

Blender Version
Broken: 2.80, 387c1f2e0d5d
I believe that I have seen this happening already on 2.79. For sure it was already happening on 2.80 Alpha.

Short description of error

Sometimes, expecially while or after having run very resource-intensive operations, Blender would start interpreting mouse and keyboard input in a strange way.
For example, numpad 1/3/7 won't change the view, and clicking on the frame bar of the timeline won't advance frames.
Some other inputs would have an effect, just not the intended one.
(I can't remember an example right now, but up until some versions ago using the mouse wheel in the viewport would change frame instead of zooming)

This happens quite consistently when the system has used a lot of resources. I have waited to open a bug because I've recently changed machine and I have more resources, but I've reached that point again and it has happened again.

Note: in my workflow I usually have Blender on a workspace, and other stuff in other workspaces (workspaces on Ubuntu are "expansions" of the desktop, made to organize windows), and I go back to check on Blender by using Ctrl+Alt+(←↓→↑) depending on where the workspace is. So maybe Blender is catching some of these keystrokes?

I've found that one way to restore normal operation is by hitting "Alt" on the keyboard several times.

Exact steps for others to reproduce the error
Unfortunately it's difficult to reproduce quickly, but I believe it happens consistently (has happened to me on two computers)

  1. Open Blender
  2. Create a basic but very memory intense simulation (i.e. use quick fluid on the default cube and crank up the resolution)
  3. Leave it to run and work on something else on a different workspace
  4. (unfortunately I haven't been able to quantify this) when Blender has been using a lot of resources for a while, go back to the workspace using Ctrl+Alt+arrow
  5. Zoom in/out or change frame using the mouse. It won't work as intended.
  6. Hit Alt several times, it will restore normal operation.

Details

Type
Bug

Event Timeline

@Nicola De Mitri (nicolasap) As you are saying that it is after memory intensive could you also check if it happens when your system is swapping? Eg it need to load back the resources that ubuntu has stored temporarily on disk.

Sebastian Parborg (zeddb) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Jun 12 2019, 3:29 PM

This sound more like a system issue and not a blender issue.
It sound like your system get so overloaded that it doesn't send "key up" events to blender. So blender will still think that certain keys are pressed.

As stated, could you check it your system is swapping?

Demeter Dzadik (Mets) closed this task as Archived.EditedJul 19 2019, 12:27 AM
Demeter Dzadik (Mets) claimed this task.

Closing due to no response in a long time. Feel free to re-open if the issue persists after aforementioned advice on latest 2.80 daily.