Page MenuHome

Image Textures appears as solid colour in Lookdev and Shaded modes
Closed, InvalidPublic

Description

System Information
Operating system: MacOS 10.14.4
Graphics card: Intel Iris Pro 1536Mb

Blender Version
Broken: 2.80 Beta, e78770039397, 2019-05-20
Worked: 2.79

Short description of error:
When following these steps;

  1. Open a new blender file
  2. Add a material/or remove the existing material and add a new material
  3. Change the colour at the dot to image texture
  4. Select file and click open
  5. Select the image texture
  6. Switch to look dev mode

in a newly open Blender file and working with an unmodified cube the image textures all load as solid colours. This is the troubleshooting that was done:

  • Restarted machine and Blender
  • Retry on other meshes, different sized meshes
  • Contacted support (this is of a Udemy Blender course), sent them the screen videos of the problem, sent them the actual blend.file. Support was able to apply image texture to my blend file with no issues
  • Deeply uninstalled Blender and reinstalled again, restarted machine as well
  • Attempted again with unmodified cube (and later a model I've been working on)
  • Still seeing image texture as a solid colour

NB: All the image textures attempted are part of the source files of an online class, these same source files are what is being used by everyone else (including the support guy that helped me) so they must be working. Additionally these image texture files were the same ones that worked fine when doing this exercise in version 2.79

The screen vids and .blend file are on Google Drive via this link:
https://drive.google.com/drive/folders/1n0uc9-cEeOtmwyRbKTdW3qbRecVAht7b?usp=sharing

Exact steps for others to reproduce the error
The person helping me reported that they were able to both apply the image texture successfully both to an unmodified cube, and to my actual blend file from Google Drive, meaning so far the error seems to be just me...

I look forward to your feedback and sincerely hope this is just my dumb human error (PEBCAK)

Kindest Regards
Dee Masuku

Details

Type
Bug

Event Timeline

William Reynish (billreynish) closed this task as Invalid.

Your model doesn't have a UV map:

Either add a UV map or use a different texture coordinate method:

If you do this, images will show normally.

Also, I should add that I can see you are using an older version of Blender 2.8.

And more importantly, you aren't using the factory default settings, which is why your cube doesn't have UV coordinates. You seem to be using a setup ported from 2.79.

I would advise you to update your Blender version, and to use the defaults, by going to File > Defaults > Load Factory Settings. Then do File > Defaults > Save Startup File.

Hi William

I hope you're well and thanks for the response!
I didn't realize about the ported setup, once I reset everything to default it all worked perfectly.

Thanks again and have an awesome week!

Kindest Regards
Dee Masuku