Page MenuHome

Vertex colors wrong in vertex paint mode
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 8
Graphics card: RX580

Blender Version
Broken: 2.80-a1ad71304c2d-win64 (latest)
Worked: 2.76

Short description of error
In object mode, with solid display, flat lighting, and vertex colors my objects have the right colors in the display (or at least very close to the right colors). When I enter vertex paint mode the selected object gets darker.

Exact steps for others to reproduce the error
Open a new general file. Make sure you are in solid display mode with flat lighting and vertex colors (from the drop down next to the display modes in the top right of the 3D view). Enter vertex paint mode. Right click to choose a color (I used 0.2, 0.8, 0.4 RGB). Shift + K to fill the cube with that color. Switch between vertex paint and object mode to view the difference.

You can also hover over the cube and then press s to sample the color, then shift k to fill the cube again and the color will change. After doing this a few times my cube turned black.

Details

Type
Bug

Event Timeline

William Reynish (billreynish) closed this task as Archived.

This is not a bug but a design issue.

It’s because Vertex Paint mode adds a multiplied layer of vertex colors on top of the viewport. If you also set the shading to Vertex Color, you see the vertex colors displayed twice, multiplied.

To see the vertex colors cleanly, either disable the Vertex Color overlay, or turn off Vertex Color in Shading.

This is not super obvious, and I can see why one would be confused by this. Don’t have an apparent solution though.