Page MenuHome

orbit around selection not working correctly in deformed mesh
Closed, ResolvedPublic

Description

System Information
Operating system: Linux-4.9.0-9-amd64-x86_64-with-debian-9.9 64 Bits
Graphics card: GeForce GTX 1060 6GB/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 390.116

Blender Version
Broken: version: 2.80 (sub 72), branch: blender2.7, commit date: 2019-05-25 19:22, hash: rB36ae49502bbe
Worked: (optional)

Short description of error
Preferences set to orbit around selection in the navigation menu!
A deformed mesh cannot be orbited around selected vertex if it was deformed by an armature and edited with the armature deformation visible in the editor.

Exact steps for others to reproduce the error

  1. set preferences to "orbit around selection" in the navigation menu
  1. open example file attached:

    bigger mesh has armature modifiers visibility set to off in editor mode, small mesh has it set to on.
  1. choose a vertex of the big mesh and rotate around with the middle mouse button -> is working choose a vertex of the small mesh and rotate around with the middle mouse button -> not rotating correctly (seems to rotate around the undeformed mesh's vertex

Details

Type
To Do

Event Timeline

Jacques Lucke (JacquesLucke) triaged this task as Confirmed, Medium priority.May 27 2019, 2:41 PM
Campbell Barton (campbellbarton) closed this task as Resolved.
Campbell Barton (campbellbarton) lowered the priority of this task from Confirmed, Medium to Normal.

This isn't a regression since 2.7x, setting as TODO.