Page MenuHome

Null audio device and AV Sync halts playback
Closed, ResolvedPublic

Description

System Information
Operating system: Linux-4.19.45_1-x86_64-with-glibc2.9 64 Bits
Graphics card: TITAN X (Pascal)/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 430.14

Blender Version
Broken: version: 2.80 (sub 72), branch: blender2.7, commit date: 2019-05-26 22:34, hash: rBd525c76003b3
Worked: A few weeks before

Short description of error
When changing the Audio Device to "Null" in the Preferences, AV-Sync playback locks up.
Switching back to "No Sync" or "Frame Dropping" returns to normal behavior and hitting space bar plays the scene once again.

Exact steps for others to reproduce the error

  • Choose "Null" option in Audio Device settings.
  • Switch to "AV Sync" (or "Jack") in playback options
  • Hitting space bar tries to play but stops immediately on the same frame.
  • Other playback options work fine
  • Additionally, switching to "Jack" on linux without it installed causes a short hang (~7s on my machine) but doesn't crash Blender, even after multiple attempts. AV Sync lock behavior is present here as well.

Event Timeline

I cannot reproduce it.
But maybe it is related to T64644?

Are you able to reproduce the issue explained there?

That works fine on my end.
Just tried resetting my preferences real quick and then it works again.
Maybe it's something I've set up in my startup file / preferences?
I've attached a scene where it's not working with my current setup together with my user prefs and startup file.
Only changed some basic preferences and some UI, so it looks like something I've set up a specific way.

I'll download todays build and see when the bug occurs when setting up my startup and prefs.

Found the issue while reconfiguring from scratch, changing the Audio Device in the preferences to "Null" halts playback.
I've updated the description to reflect the issue more clearly.

William Reynish (billreynish) closed this task as Archived.

This doesn't seem like a bug. If there is no audio device, then there is no audio to sync with.

I don't really know why we have the option of setting the Audio Device to Null - @Brecht Van Lommel (brecht) any idea why we have this?

Brecht Van Lommel (brecht) triaged this task as Confirmed, Low priority.

I guess it's mainly if you are building without audio, or need it as a workaround if there is some issue with with audio.

Still would consider this a bug, but a low priority one.

Brecht Van Lommel (brecht) renamed this task from Setting timeline to AV Sync halts playback to Null audio device and AV Sync halts playback.May 29 2019, 1:01 PM

OpenAL tends to mess with some of the other PulseAudio devices when starting Blender, causing recordings to get garbled or internal sample rates to get mixed.
This can happen during streaming sessions or whilst having other audio editing applications open.
I tend to set it to "Null" so it doesn't interfere with the other open applications.

@William Reynish (billreynish) perfectly described it when he wrote

If there is no audio device, then there is no audio to sync with.

So the behavior is intended! The only thing I could think of that we could change here is to disable/hide A/V sync when the audio device is Null.

The only thing I could think of that we could change here is to disable/hide A/V sync when the audio device is Null.

That's what it should do, just silently disable AV-Sync, not break playback.

What happens if you open a file that has AV-sync set? There you'll have the same behavior still. Or you set the synchronization to something else, which might not be what the user wants. I'm a bit hesitant in changing stuff without letting the user know. Especially, I would expect a file not to change if I only open and save it - independent of my user preference settings.

The user interface or settings should not change, it should just not do A/V sync in the playback operator. If there is no audio device playing back audio, there no syncing to audio to be done, I don't think the user needs to be notified about that.