Page MenuHome

Convert curve with bevel object to mesh only working if depth is nonzero
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.17134 64 Bits
Graphics card: GeForce GTX 1080 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 411.70

Blender Version
Broken: version: 2.80 (sub 72), branch: blender2.7, commit date: 2019-05-27 19:48, hash: rB89207df7222a
Worked: (optional)

Short description of error
Convert curve with bevel object to mesh only working if bevel depth is not Zero.
Convert should not only check bevel depth but also if bevel_object is assigned.

Exact steps for others to reproduce the error

  • create two curve objects
  • set one as the bevel object on other curve
  • convert beveled curve to mesh (it will not convert the beveled result but only the curve)
  • set bevel depth to something different than 0, now it will work

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.May 29 2019, 9:59 AM

Please follow our submission template and guidelines, also read these tips about bug reports, and make a complete, valid bug report, with required info, precise description of the issue (only ONE issue per report!), precise steps to reproduce it, small and simple .blend and/or other files to do so if needed, etc.

I cannot reproduce with today's build from quick try (hard to be sure without a file to try though), this should have been already fixed iirc…

Enzio Probst (enzio) closed this task as Resolved.May 30 2019, 2:21 PM
Enzio Probst (enzio) claimed this task.

Checked again and Works in
version: 2.80 (sub 72), branch: blender2.7, commit date: 2019-05-29 18:17, hash: fee600f47980, type: Release