Page MenuHome

Sub surface scattering yields incorrect results with bevel shader node.
Closed, InvalidPublic

Description

System Information
Operating system: Windows-10-10.0.17763 64 Bits
Graphics card: GeForce GTX 1080/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 390.77

Blender Version
Broken: version: 2.80 (sub 60), branch: blender2.7, commit date: 2019-05-07 19:17, hash: rB3dc9da3a74ee
Worked: (optional)

Short description of error
Subsurface scattering does not produce the expected results when using the bevel shader node. Applying a strong normal map definitely shows that SSS is taking the normal information into consideration in some way, but the underlying hard geometry is followed more than the intended shapes dictated by the normals.

Exact steps for others to reproduce the error
See attached image for shader and comparison

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

The bevel shader can fake rounded corners to an extent. But it can not be expected to give accurate results for random walk SSS, which is based on volumetric scattering within actual geometry.

Daniel Bystedt (dbystedt) changed the task status from Archived to Invalid.
This comment was removed by Daniel Bystedt (dbystedt).

SSS in combination with normal maps works (both random walk and Christensen-Burley). Therefore this bug report is invalid{F7080389}


2.8 test system spec
Blender Version
Broken: version: 2.80 (sub 73), branch: blender2.7, commit date: 2019-05-30 17:34, hash: rB846056de6b27
Worked: (optional)

Beveling incoming normals is not supported in stable blender 2.79 either
2.79 test system specs
version: 2.79 (sub 7), branch: blender2.7, commit date: 2019-05-23 08:19, hash: 054dbb833e15, type: Release
build date: 30/05/2019, 10:01
platform: Windows
binary path: 'E:\\Users\\Daniel\\Downloads\\blender-2.79-054dbb833e15-win64\\blender-2.79.0-git.054dbb833e15-windows64\\blender.exe'