Page MenuHome

Mirror modifier potential bug
Closed, InvalidPublic

Description

System Information
Operating system: Windows-10-10.0.17763 64 Bits
Graphics card: GeForce 940M/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 376.54

Blender Version
Broken: version: 2.80 (sub 72), branch: master, commit date: 2019-05-25 23:18, hash: rBf18373a9ab1a
Worked: (optional)

Short description of error
When using the mirror modifier and subdivision surface, the mirrored edges don't get smooth, even when the modifier is applied. (with the subsurface at the bottom) settings like clipping, merge etc. all don't solve the problem.

Exact steps for others to reproduce the error
For example:
1-create a flat circle with 16 vertices, with a face and a hole in the middle;
2-delete 3/4th of the circle, leaving a quarter;
3-activate a mirror modifier and tick the axes so you'll have a complete circle with a hole in the middle
4-activate a subdivision surface modifier (after the mirror)
5-go into edit mode, and extrude the circle

Normally, you would have a completely round donut. However, at the mirror axes the subsurf doesn't work and there's a sharp corner

. It does work however, if you extrude the circle before activating a mirror modifier. Note that I haven't applied any modifiers, and the two objects are completely the same. So, according to the non-destructiveness of the modifier workflow, the objects should be the same, but they're not.

Details

Type
Bug

Event Timeline

Aren't there inner faces at the mirror axes in one of the meshes, while they are not there on the other? Can you provide your blend file?

From the screenshot it seems like you have inner face that emerged after extrusion and not cleaning up the mesh, also yourbevel settings are unknown. I couldn't recreate this bug after following your steps. But I do get inner faces after extrusion if I don't cleanup the geometry...

- This looks like your problem.

- Delete inner faces after extrusion.

- Works Perfectly.

Thanks for your reply, it were indeed the inner faces.
I wasn't entirely sure whether it was a bug or just me, because I couldn't find such a problem anywhere, and it didn't happen on the 2.7 version.

Wow, It seems that you are correct. Seems like 2.79's mirror modifier would clean the inner faces automatically if they are to clip together. Probably 2.8 modifier works a bit differently. Now I'm not really sure if it is working as intended.

Bastien Montagne (mont29) closed this task as Invalid.
Bastien Montagne (mont29) claimed this task.

Thanks for the report, but there is indeed no bug here. It’s not the role of the mirror modifier to *remove* existing faces, it only *merges* items (be it vertices, edges or faces), never actually removes them.