Page MenuHome

Cycles completely broken
Open, Needs Information from UserPublic

Description

System Information
Operating system: macOS 10.14 (Darwin-18.6.0-x86_64-i386-64bit 64 Bits)
Graphics card: AMD Radeon R9 M395X OpenGL Engine ATI Technologies Inc. 4.1 ATI-2.9.26

Blender Version
Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-06-15 03:38, hash: rBaaf65749e9df
Worked: (optional)

Short description of error
Cycles doesn't work at all

Exact steps for others to reproduce the error

  • Open Blender 2.8, latest master
  • switch renderer to Cycles
  • Render or set shading to Rendered

Nothing will appear

Details

Type
Bug

Event Timeline

Seems to be working on Linux with latest daily build:
2.80 (sub 74), branch: blender2.7, commit date: 2019-06-14 23:24, hash: rB0fd96b4128ff

On macOS I get a completely blank display, also when doing final renders.

I compiled a new Blender on mac ,seems cycles works for me. either view shading mode or F12.

Operating system: Darwin-18.6.0-x86_64-i386-64bit 64 Bits macOS 10.14.5
Graphics card: AMD Radeon Pro 450 OpenGL Engine ATI Technologies Inc. 4.1 ATI-2.9.26

version: 2.80 (sub 74), branch: master, commit date: 2019-06-15 03:38, hash: rBaaf65749e9df

Tested on laptop with integrated graphics: Cycles works here

It seems like this issue it local to my iMac.

The default scene in Cycles just looks like this:

Are your popup menus and drop down menus from the menu bar transparent by any chance...? Then it could be related to UI graphics glitches on macOS with Intel HD 4000...?

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.Thu, Jun 20, 2:50 PM