Page MenuHome

Brush icons show all the same under Draw
Confirmed, LowPublicKNOWN ISSUE

Description

System Information
Operating system: Darwin-15.6.0-x86_64-i386-64bit 64 Bits
Graphics card: Intel Iris Pro OpenGL Engine Intel Inc. 4.1 INTEL-10.14.74

Blender Version
Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-06-27 21:28, hash: rB5dd8c3f0cb83
Worked: 2.79

Short description of error
When choosing a brush type under draw, all icons show the same.

Exact steps for others to reproduce the error

  1. Select Weight Paint
  2. Select Draw Brush
  3. In the properties panel choose Tools
  4. Select Brush type

In 2.79 there would show different icons for different types. This new method is a bit confusing now but also shows the same icon for eah and every type. Not sure why these havent been update before the UI Freeze

Also Smear uses a copy brush, its shows as Smear.001

Same as in workspace, there are quite a couple of names which should not be there. This is the default startup file, notice those default.00 numbered screens. Seems like old leftovers. Ive noticed them for months now.

Event Timeline

William Reynish (billreynish) lowered the priority of this task from 90 to 50.Jun 28 2019, 10:15 AM

Please only report one issue per report, otherwise it's hard to track this.

The screens thing is a clear mistake, which should be fixed.

The brush icons we should remove completely in favor of a generated preview. Short term, I think there's no need for all these separate brushes for blend modes, when you can just change the blend mode directly:

Brecht Van Lommel (brecht) lowered the priority of this task from 50 to Low.Jul 3 2019, 4:18 PM

I think the presets are handy and will make it easier for newcomers.

Should i make a new post concerning that work area and none used screens?

Richard Antalik (ISS) changed the subtype of this task from "Report" to "Known Issue".Feb 5 2020, 11:34 AM