Page MenuHome

Crashes after a few seconds of sculpting
Closed, ArchivedPublic

Description

System Information
Operating system: Linux-4.15.0-54-generic-x86_64-with-debian-buster-sid 64 Bits
Graphics card: AMD Radeon (TM) RX 460 Graphics ATI Technologies Inc. 4.5.13556 Core Profile Context 19.10.9.418

Blender Version
Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-06-24 18:46, hash: rBc0c1b4542f39
Worked: (optional)

Short description of error
Crashes after a few seconds of sculpting, since last couple of builds, normal 2.8 and the sculpt-mode

Exact steps for others to reproduce the error
I start blender, change to sculpt mode, just normal brush, and blender crashes/disapears, after a couple of brush strokes.
It happens if I set the file > new > sculpting, or just a normal new file and start sculpting, using pure geometry, or using multires modifier, not even trying dyntopo :(

note: This have been happening for at least a week for different builds, on this machine. It doesn't happen at works when Im using blender full time on a much better machine and in windows. So I think it should be an os/drivers thing, and I have been updating my system to see if it helps.

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

I can't seem to reproduce this on my linux machine.
Are you running the latest proprietary drivers?
Have you tried the open source drivers?

Sorry, im not even sure, I tried a couple of things, does this help?

*-display                 
     description: VGA compatible controller
     product: Baffin [Radeon RX 460/560D / Pro 450/455/460/555/560]
     vendor: Advanced Micro Devices, Inc. [AMD/ATI]
     physical id: 0
     bus info: pci@0000:01:00.0
     version: cf
     width: 64 bits
     clock: 33MHz
     capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
     configuration: driver=amdgpu latency=0
     resources: irq:126 memory:e0000000-efffffff memory:f0000000-f01fffff ioport:e000(size=256) memory:f7e00000-f7e3ffff memory:c0000-dffff

and:
~$ lspci -nnk | grep -i vga -A3 | grep 'in use'
Kernel driver in use: amdgpu

in any case, i haven't change the drivers in a while and that only started happening a week or so ago.

Ill try remove this and go with the open source ones, and see how it goes. (in a day or so)

Please do, it will be very useful for us to know if this is just an issue with the closed source drivers.

Had some troubles with removing the drivers but luckly didn't had to reinstall ubuntu, it does work now! have been modelling for about 10 minutes when it always crashed in about 10 seconds, so it was my drivers then.

Oh, I thought you were running debian.
Which ubuntu version are you using?

I'm on ubuntu 18.04, with the default gnome desktop.

Sebastian Parborg (zeddb) closed this task as Archived.Jul 5 2019, 2:11 PM
Sebastian Parborg (zeddb) claimed this task.

Ok, then I think that you might have more luck with 19.04 (if you want to try the closed source drivers again).

We can't reproduce this issue with the latest closed source drivers on our end. So I'll go ahead and close this.
If you have problem with the latest closed source driver, we can reopen this.

I dont find any difference and it is working now (I couldn't use gpu for cycles anyway) so Ill keep using this one, thank you for the sugestion, you fixed it for me :)