Page MenuHome

UV Editor: "Select More" operator is completely broken in Face mode
Closed, ResolvedPublicBUG

Description

System Information
Operating system: Windows-10-10.0.17134 64 Bits
Graphics card: GeForce GTX 1080 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 417.22

Blender Version
Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-07-02 13:31, hash: rBe7356bb01198
Worked: (optional)

Short description of error
While in face mode, if you try to run the UV Select More operator, it appears to select the last selected set of loops from another selection mode (if one exists). Vert and Edge mode do not seem to be affected by this.

Exact steps for others to reproduce the error
Select a Face in the UV editor and try to run the UV Select More operator. If you just started Blender- likely nothing will happen (no selection growth or anything).
Now go into vert or edge mode and run the same operator a few times to grow the selection out as expected. make note of what the selection looks like so you can compare.
Now go into face mode again and select some completely unrelated area and run the operator- the last selection reappears instead of the expected result.
See the attached video:

Event Timeline

Sebastian Parborg (zeddb) lowered the priority of this task from 90 to 50.
Brecht Van Lommel (brecht) lowered the priority of this task from 50 to Low.
Brecht Van Lommel (brecht) changed the subtype of this task from "Report" to "Bug".Jan 27 2020, 11:47 AM
Brecht Van Lommel (brecht) edited projects, added Modeling; removed Tracker Curfew.

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 1080/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 442.59

Blender Version
version: 2.83.1, branch: master, commit date: 2020-06-25 09:47, hash: rB8289fc688b3e

I can not reproduce the error that is described above. Everything is working as expected on the version of Blender that I'm running

Yes, I can confirm that this appears to be working in 2.83 LTS. Not sure when it got fixed (or by what commit), but this task can be closed.

eldee smith (eldee) closed this task as Resolved.Tue, Jun 30, 12:19 AM
eldee smith (eldee) claimed this task.