Page MenuHome

Crashes a lot in Blender 2.8 EEVEE using linux and amd gpu-pro driver 19.20 with error:GPUTexture: texture alloc failed. Likely not enough Video Memory.
Closed, ResolvedPublic

Description

System Information
Operating system: Ubuntu 18.04.2 LTS
Graphics card: ASUS ROG-STRIX-RX580-8G-GAMING
System Memory: 16G DDR4

Blender Version
Broken: Blender 2.80 (sub 74), Commit date: 2019-07-06 22:58, Hash e106765c9682
Worked: (optional)

Short description of error
It happened a lot while using EEVEE in the viewport,Sculpting,Weight painting,Render to FFmpeg video,happened more often especially if change Cascade Size to 4096 in Shadows from Scene Panel.

Exact steps for others to reproduce the error
Open blender 2.8 with default cube, window maximized,change Cascade Size to 4096,then switch viewport to Rendered( using EEVEE),on my system it crashes everytime.

Details

Differential Revisions
D5205: GPU: ATI Proxy check
Type
Bug

Event Timeline

Hi @john steave (allked),

I am able to reproduce this one, (Cascade Size to 4096) with the latest AMD Pro Drivers.
For completeness can you upload your system_info.txt (Help => Save System Info).


Jeroen Bakker (jbakker) triaged this task as Confirmed, High priority.

Can't reproduce this with the open source drivers, so I guess this is a closed source bug.

Jeroen Bakker (jbakker) closed this task as Resolved.Jul 9 2019, 12:14 PM

Ok closing as the fix for the work around for source drivers has been added.

We are always interested in any other reproduceable crashes. Thanks for the report.

I updated to blender-2.80-3b4054cb586f-linux-glibc217-x86_64,I can not produce the problem again,I will try with my big scene now ,this is my system info: thanks