Page MenuHome

Planar scale handles of scale gizmo are extremely sensitive
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.17763 64 Bits
Graphics card: GeForce GTX 1080 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 430.64

Blender Version
Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-07-07 23:53, hash: rBbb2abacb4b5c
Worked: (optional)

Short description of error


Planar scale handles of scale gizmo are extremely sensitive. Since scale sensitivity is modulated by the distance of the mouse cursor from the center of the scale gizmo, and since planar scale handles are very close to the center, it is absolutely not possible to perform subtle planar scale tweaks, as the sensitivity is out of control even when moving mouse cursor by one pixel.

Exact steps for others to reproduce the error

  1. In a new .blend file, select default cube

2, Switch to scale tool and scale the cube on any planar axis
3, Notice the planar scale sensitivity is much higher than when scaling individual axes by dragging handle ends or scaling uniformy using the outer ring.

Result: Planar scale handles of scale gizmo are extremely sensitive
Expected: Scale sensitivity modulation based on the distance of mouse cursor from the action center is disabled for gizmos, and used only for legacy 2.79 style transform tools.

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

Please use devtalk for user feedback like this.