Page MenuHome

Extrude faces along normals not workking as expected
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 10
Graphics card: Intel HD Graphics 4000

Blender Version
version: 2.80 (sub 74), branch: master, commit date: 2019-07-05 16:36, hash: 699193713fc0, type: Release

Short description of error
The extrude tool transfers the existing faces to the new vertices as expected.
Extrude faces along normals

Expected:  transfer the existing faces to the new vertices.  
Actual: creates new faces for the new vertices and leaves the existing faces on the existing vertices.

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).

Add a cube
Set Edit mode
Select one face and extrude with the extrude tool.
Delete the extruded face to inspect the original vertices.

As expected there is no face attached to the original vertices.

Add a cube
Set Edit mode
Select all faces and extrude with "Extrude faces along normals" .
Delete one extruded face to inspect the original vertices.

Expected: there is no face attached to the original vertices.
Actual: there is a face and we have an unwanted cube within the cube.

Details

Type
Bug

Event Timeline

issue can be reproduced on linux OpenSUSE Tumbleweed - GTX690 - AMDFX 8350 - 16G


2.7x also works the same, so I guess this is how it works?

Sebastian Parborg (zeddb) closed this task as Archived.
Sebastian Parborg (zeddb) claimed this task.

We do not consider this a bug as this is how it has worked for a very long time.