Page MenuHome

Overlayed Shadows darken stacked areas
Closed, ArchivedPublic

Description

System Information
Operating system: win 7
Graphics card: gtx 1060

Blender Version
Broken: Release Candidate 1

Short description of error
This problem NEVER existed in the previous versions of the beta from April to May.
what happened?!

(Current Release Candidate)

This is what it's supposed to look like (May 4, 2019)

I already tried adjusting the alpha and opacity, no fix.
This should really be a high priority because 2.80
is about to be released.

Details

Type
Bug

Event Timeline

@Brecht Van Lommel (brecht) This area of code did not changed for months, so not sure what could be the reason.

@Randell Acuram (Ranakade) Could you provide any simple blend file with the problem?

Brecht Van Lommel (brecht) triaged this task as Needs Information from User priority.Jul 14 2019, 7:34 PM

Back in May, the shadows wouldn't do this kind of thing
*Forgive me for reacting earlier, I was a bit jumpy when I noticed this issue.
where the opacity doubles when strokes are overlapping each other.

@Randell Acuram (Ranakade) I'm not sure what you expect, but looking at your file the overlap is working as expected.

IIRC there was a change in how the multiply worked because there was bug, maybe this bug is what got the old result you had, but this was wrong. If you have two overlaped areas, the color must be darker.

To solve the issue in your drawing is very easy... just reshape the shadows strokes to no overlap, or just join the shadow area in one stroke only. This last solution is the best because you reduce the number of points and you will get better FPS.

@Brecht Van Lommel (brecht) I think we cannot consider this as a bug, no?

@Antonio Vazquez (antoniov), that's up to you to decide.

I imagine it would be useful to have a way to merge all those areas together automatically rather than doubling up shadows. But if existing functionality is supposed to be able to do that I don't know. If not then close as not a bug.

@Antonio Vazquez (antoniov), that's up to you to decide.
I imagine it would be useful to have a way to merge all those areas together automatically rather than doubling up shadows. But if existing functionality is supposed to be able to do that I don't know. If not then close as not a bug.

it was much easier to work without the overlaying shadows doubling the opacity in the past, at least i thought so.

Antonio Vazquez (antoniov) closed this task as Archived.

I know what you mean, and in this case you would be right, but the problem is the old mode was wrong... any artist expect that if you draw two times on the same place with a semitransparent color, the color will get darker that only one stroke. If draw three times, more darker and so on.

Anyway, we have planned to do a redesign of the blend modes in 2.81 (T66293), so I'm going to take a note to review if it's possible to have this "no-overlap" as an option and make easy this type of shadows.

Thanks for your report, but as this is not a bug, I'm going to archive it.

I know what you mean, and in this case you would be right, but the problem is the old mode was wrong... any artist expect that if you draw two times on the same place with a semitransparent color, the color will get darker that only one stroke. If draw three times, more darker and so on.
Anyway, we have planned to do a redesign of the blend modes in 2.81 (T66293), so I'm going to take a note to review if it's possible to have this "no-overlap" as an option and make easy this type of shadows.
Thanks for your report, but as this is not a bug, I'm going to archive it.

Alrighty no problem. thx for looking into it though. :-)