Page MenuHome

Blender 2.8 crash with AMD RX 5700 Series GPU's
Closed, ResolvedPublic

Description

System Information
Operating system: WIndows 10 Home 64, Version: 1903, OS Build: 18362.239
Graphics card: AMD RX 5700 XT
CPU: Ryzen 7 2700X

Blender Version
Broken: 2.8 RC1 and previous 2.8 candidates
Worked: 2.8 with Geforce 1060 6GB, 2.79 with RX 5700 XT

Short description of error
After upgrading from a GTX 1060 6GB GPU to an RX 5700 XT I am unable to open any Blender 2.8 version.
My Partner built a new system with a Ryen 5 3600x and the RX 5700 and it does the same error.
It works with 2.79 but as soon as we try the 2.8 builds it freezes almost instantaneously.
No luck with any of the debug options as well. Can't get any crash report info as the debug file is blank.

Exact steps for others to reproduce the error
Use an RX 5700 series GPU.

Details

Type
Bug

Event Timeline

Matt Knoff (mcknoff) triaged this task as Waiting for Developer to Reproduce priority.Jul 13 2019, 8:07 AM
Matt Knoff (mcknoff) raised the priority of this task from Waiting for Developer to Reproduce to Needs Triage by Developer.Jul 13 2019, 8:19 AM

These cards are really new, so you may be one of the first trying this. In theory it ought to work, but I have not found any benchmark or test results with Blender yet. I did find one review that stated they had problems with Blender: https://www.anandtech.com/show/14618/the-amd-radeon-rx-5700-xt-rx-5700-review/13

Unfortunately, as I mentioned earlier in my testing observations, the state of AMD's OpenCL driver stack at launch is quite poor. Most of our compute benchmarks either failed to have their OpenCL kernels compile, triggered a Windows Timeout Detection and Recovery (TDR), or would just crash. As a result, only three of our regular benchmarks were executable here, with Folding@Home, parts of CompuBench, and Blender all getting whammied.

You mention both freezing and crashes. Can you describe in more detail the behavior you see? Does the Blender UI come up at all etc.

Can you try executing Blender from a Windows Command Prompt window so any output from a crash will be visible after it exits?

Can you add the output file from Help->Save System Info to the ticket?

And of course, be sure you have the absolute latest drivers from AMD.

I am also experiencing this issue, I can provide more details as to what happens.

GPU: Ryzen 5700
AMD Drivers: 19.7.1
CPU: i7-4770k

When running Blender 2.8 RC1 and the 2.8 beta, the application fails to launch. The UI doesn't come up, and the screen is white before it causes the gpu to reset. This requires using the task manager to end blender and the radeon processes.

Running Blender 2.79 however still launches properly.

This is what I get when I run the blender force gpu workaround.

Here is the System info file as well.

I have the same problem when running the 2.8 rc and beta, the application fails (black screen and help only computer reboot)

Blender 2,79 launches properly

GPU: RX 5700
AMD Drivers: 19.7.1
CPU: i5-4690K

I also have the same issue with the 2.8 release candidate. 2.79 works fine though.

For me it opens to a gray window and then freezes, gpu resets, and Blender is only a gray screen and frozen. Have to use task manager to end.

This is with the latest version of windows and latest AMD drivers.
GPU is the 5700 XT. CPU is Ryzen 5 3600.

Sebastian Parborg (zeddb) triaged this task as Normal priority.

@Brecht Van Lommel (brecht) @Jeroen Bakker (jbakker) this sounds like a AMD driver issue. Do you have any AMD contact person?

(Marking it as Normal as it seems quite a few people have this issue)

Brecht Van Lommel (brecht) raised the priority of this task from Normal to Confirmed, High.EditedJul 15 2019, 3:52 PM

We're in contact with AMD about this issue, but there is no fix yet.

There's a new AMD driver version coming soon that should fix this issue.

Hi All,

Can anyone test blender with the new drivers and verify that we can close this issue?

Thanks

Hi i made an update using AMD drivers (19.7.2), not clean instal

Blender 2,8 launches properly (new version download), I have not tested too much.

Blender 2,79 launches properly

GPU: RX 5700
AMD Drivers: 19.7.2
CPU: i5-4690K

Can you try doing a render in Cycles in GPU Compute mode with the card selected as the Cycles OpenCL device?

Jeroen Bakker (jbakker) closed this task as Resolved.Jul 18 2019, 9:48 AM

I am closing this issue.
Please continue with the Cycles OpenCL test. There are some known issues related to Windows + VEGA T65924: Cycles render crash GPU RX Vega 56. If there are issues related to OpenCL Cycles rendering on Windows using Navi please use that ticket.

Dear Gavin,

Can you please respond with the benchmark results? Currently there is no benchmark result for rx 5700 cards. Gamersnexus claims to have results but noone else has been able to run it.

While I haven't been hunting for them specifically, I have yet to see a report confirming that OpenCL Cycles rendering works in the latest driver. But I haven't seen anyone say it doesn't work yet either. (I don't have one to try).

What exactly do you need? I started this thread and I am satisfied with the new drivers allowing me to open blender 2.8 and render with opengl. I have rendered multiple scenes, probably over 50 since getting it to work.

Really just verification that it's working so thanks for that. Sounds like things are good.