Page MenuHome

Bake of the second particle system after duplication and making it unique makes mess.
Open, Confirmed, MediumPublic

Description

System Information
Operating system: Windows-7-6.1.7601-SP1 64 Bits
Graphics card: GeForce GTX 660 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 430.86

Blender Version
Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-07-14 21:02, hash: rB65168825e0b0
Worked: version: 2.79 (sub 7), branch: blender2.7, commit date: 2019-05-23 08:19, hash: 054dbb833e15, type: Release
build date: 24/06/2019, 17:18

Short description of error
If you duplicate particle settings, make them unique, and tune, bake of dynamica will broken.

Finally I found how to reproduce it.

Create plane,
Create particle system that emits cubes (color A) from -50 to 50 frame with short lifetime (20).
Duplicate particle settings, make settings unique, rename it.
Change instance to another cube (color B), change working period to 50 — 100 frames.
Check work in the viewport. Bake all dynamics, Revert file.

Messed:

Bug is not appere only if you create separate fully independent settings in the fresh file.
With independently created particles systems

Perhaps it can be connected with T61963
Looks like some data just stucks

Details

Type
Bug

Event Timeline

Vyacheslav (hitrpr) renamed this task from Two particle systems in one object: bake of the second is empty each time to Bake of the second particle system is empty each time.
Vyacheslav (hitrpr) renamed this task from Bake of the second particle system is empty each time to Bake of the second particle system after duplication and making it unique makes mess..
Sebastian Parborg (zeddb) triaged this task as Confirmed, Medium priority.

@Sergey Sharybin (sergey) seems like something in the caching system is messed up. If I delete the cache slots and add new ones, it works again.

Sergey Sharybin (sergey) lowered the priority of this task from Confirmed, Medium to Needs Information from User.Jul 17 2019, 12:49 PM

@Sebastian Parborg (zeddb), did you manage to reproduce it from scratch?
@Sebastian Parborg (zeddb), @Vyacheslav (hitrpr) Is it a regression compared to 2.79?
Copy-pasting the plane to 2.79 exhibits the same behavior for me.

Vyacheslav (hitrpr) added a comment.EditedJul 17 2019, 7:24 PM

@Sergey Sharybin (sergey) just baked similar scene with 2.79 and all work as indended. No bugs. So yes, it is regression.

@Sebastian Parborg (zeddb) I confirm, that scene will work in viewport fine, after clearing all caches, saving and reverting file. But baking is impossible for me.

Sebastian Parborg (zeddb) raised the priority of this task from Needs Information from User to Confirmed, Medium.Jul 19 2019, 11:02 AM

@Sergey Sharybin (sergey) I can confirm that this does seem to work in 2.79

The same. States of system do not jump and bakes properly.
Here the comparison