Page MenuHome

Crash on Unwrapping
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 7
Graphics card: GTX 760

Blender Version
Broken: (blender-2.80rc1-windows64)
Worked: (optional)

Short description of error
Pressed U inside of UV editor after making selection in edit mode then crashed. Reloaded auto save was able to one set before I pressed U again and it crashed.

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).
Multiple objects in file not sure if I should export out the piece its crashing on, let me know.

Details

Type
Bug

Event Timeline

Developers won't be able to help you if you don't provide a blend file.

Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.

@Garrett Barco (Garrett_Barco): The .blend file with just the offending object [nothing more] should be sufficient.

Demeter Dzadik (Mets) raised the priority of this task from Needs Information from User to Needs Triage by Developer.

Could not reproduce. Anyone else?

matc (matc) triaged this task as Needs Information from User priority.

I can't reproduce either. But there is definitely something going wrong. I can't see the model once I'm in the UV Editing workspace. After splitting the 3D Viewport it will appear but only in the newly created viewport. @Demeter Dzadik (Mets) is this the case for you too?

@Garrett Barco (Garrett_Barco) Did you create the file from scratch with the release candidate or were you initially using one of the beta builds? Do you know which version? If you are still able to cause the crash with the second release candidate, could you provide step by step instructions?

@matc (matc) Aren't you just being bamboozled by the fact that the Image Editor and the UV Editor are now two separate things? Maybe you were in the Image Editor, hence why you couldn't see the UVs then.

@Demeter Dzadik (Mets) Does this mean you do see the model in that viewport?

I initially thought I was being bamboozled by some visibility settings, but I don't think it's possible to have visibility set per viewport.

The bottom viewport is the one I see when I open the file and switch to the UV Editing workspace. I added a measurement to show that both viewports have the same zoom level. The 3D Cursor shows that both are looking at the same area.

Huh. Yeah, I can see the object the entire time while I open a UV editor, go into edit mode, and press U. Nothing seems wrong on my end :o

matc (matc) added a comment.EditedSat, Jul 27, 3:04 AM

After opening the file I only click on UV Editing. Besides the 3D cursor there is nothing visible in the 3D Viewport.

It's happening for me both on linux and windows with a RX 580. What are you using?

@Garrett Barco (Garrett_Barco) Can you provide step by step instructions to help reproduce the problem? And you should check whether there are any updates for your graphics driver available.

@matc (matc) Oh yeah, the 3d viewport in the UV Editing workspace is in local view. Press forward slash / :P

I wasn't changing workspace, I just summoned a UV editor cause I'm old school.

Didn't know that was a thing. So I have been bamboozled after all.

Sybren A. Stüvel (sybren) closed this task as Archived.
Sybren A. Stüvel (sybren) claimed this task.

Since last asking for information it has been 7 or more days, due to the policy of our bug tracker we will have to archive the report until the requested information is given.