Page MenuHome

Cryptomatte does not work in version 2.8 when create scene and nodes from scratch
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 7 SP1
Graphics card: MSI GeForce GTX 1070 Ti

Blender Version
Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-07-18 14:52, hash: 38d4483c6a51, type: Release
build date: Thu 07/18/2019, 09:28 AM
And all other 2.80 versions, I tried since May

Works fine: version: 2.79 (sub 7), branch: blender2.7, commit date: 2019-06-27 10:41, hash: e045fe53f1b0, type: Release
build date: 14/07/2019, 17:18

If I create a scene and nodes in compositor from scratch in 2.8, cryptomatte does not work, but instead shows a few light dots on a black background. If I create the scene in 2.79, everything is fine when I open it in 2.8.
If I create and save an empty file in 2.79, and then open it in 2.8, and add objects to scene and nodes to the compositor, everything is fine.
If I create a scene and the compositting settings from scratch in 2.8, render it and save result in OpenEXR Multilayer, the cryptomatte does not work in either 2.8 or 2.79 when try compose this image.

Attaches:
280example.blend -- built from scratch in 2.8, not work
279example.blend -- built from scratch in 2.79, work fine in 2.79 and in 2.8

Event Timeline

Sebastian Parborg (zeddb) lowered the priority of this task from 90 to 30.Jul 24 2019, 12:46 PM

I can not reproduce this from scratch in blender 2.8.
Could you see if this is still an issue for you with the latest build? https://builder.blender.org/download/

I manually delete preferences folder AppData\Roaming\Blender Foundation\Blender\2.80\ and use last build:


version: 2.80 (sub 75), branch: master, commit date: 2019-07-24 10:42, hash: 4fe0fafb8755, type: Release
build date: 24/07/2019, 05:09
platform: Windows

Results are same. Additional screenshots here.

Can´t confirm. Building from scratch works with the latest build.

Operating system: Windows-10-10.0.17134 64 Bits
Graphics card: GeForce GTX TITAN X/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 430.86
Graphics card: GeForce GTX 1080 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 430.86

Latest build -- RC3: everything is oK!

Sebastian Parborg (zeddb) changed the task status from Unknown Status to Resolved.Jul 29 2019, 10:55 AM
Sebastian Parborg (zeddb) claimed this task.