Page MenuHome

Blender shuts down when I try to render a scene
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce GTX 1080 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 430.86

Blender Version
Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-07-18 14:52, hash: rB38d4483c6a51
Worked: (optional)

Short description of error
When I push F12 the Render Window appears. It starts to render then the program crashes.

Exact steps for others to reproduce the error
[Please describe the exact steps needed to reproduce the issue]
Start Blender from the shortcut icon from the Windows Toolbar at the bottom of the Windows Desktop.
Blender starts normally. The splash screen appears.
Click on File. Drop down to Open.
Select setv3.blend from the list.
Click on Open Blender File. (Note: This file is 1.73 GiB so it takes a little while to load.)
The file appeared in the Layout window Object Mode. (Note: The scene appears the same way as when it was saved.)
Clicked F12. The Render Window appeared.
After about 2 minutes Blender closes.
[Based on the default startup or an attached .blend file (as simple as possible)]

FYI: I was able to render the same file in the latest experimental build blender-2.80-5f140e61c28c-win64.zip But when I tried to render a scene a second time Blender closed down.

Details

Type
Bug

Event Timeline

With last master, I managed to render with a GTX 1080 on windows (it didn't crash). It took 1 min and 55 seconds. I'm not sure, but for big scenes, or scenes rendered with a very high resolution, I managed to avoid some crashes following this tutorial http://artificialflight.org/blog/2013/cycles-crash-cuda-tdr-error/ (create a TdrDelay DWORD key in regedit and set the value to 16). If you follow this tutorial, is this working for you?

Works fine on my machine (also Windows 10 64 bit and Nvidia GeForce GTX 1080 Ti). I do get the following warnings on the console though I'm not sure if they are related to the crash you were experiencing.

libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
GPU: Blender Texture Not Loaded
Evaluate all animation - 1.000000
        No Actions, so no animation needs to be evaluated...
Skipping auto-save, modal operator running, retrying in ten seconds...
Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

Your file is way to complex. Strip it down to a minimal state to try to find out what is making your blender application crash.

Do you have any suspicions for what the main culprit (suspect) might be? I will do some troubleshooting to see if I can figure it out. But, if you find out something that seems to be messing it up I would really be thankful to hear about it.
BTW, I did remove all the textures and shading but Blender would still shutdown. Would that lead to the conclusion that it has something to do with the number of polygons or maybe a mesh problem?

Best Regards,
Craig

@Craig Kitchens (ckalan1) Have you monitored your memory usage? With a complex scene it could happen that your run out of memory.

I have monitored the memory usage and it appears to have a lot in reserve. I will check it again.

Craig

Renders here on Linux with the CPU with 16 GB memory.
Crash with a CUDA out of memory error on the GPU (GeForce GTX 1660 6 GB)

Have you tried what Sebastian said? Ie. basic troubleshooting? Start deleting parts of the scene, see if it still crashes. If it stops crashing, the problem was with whatever you last deleted. Repeat until you're down to a very small number of things that are left in the scene, and deleting any of them does not produce the crash. Then upload that.

yes. But I could not find the culprit. I will try again.

If the only correlation you can find between cases where it crashes vs does not crash is the amount of stuff in the scene, then I guess it could be a memory issue?

Bastien Montagne (mont29) closed this task as Archived.
Bastien Montagne (mont29) claimed this task.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.