Page MenuHome

blender freezes when trying to edit material name or settings
Closed, ArchivedPublic

Description

System Information
Operating system: Linux Mint 19
Graphics card: GeForce GT 610 and GeForce GTX 1050

Blender Version
Broken: v 2.80 Release Candidate 2
Worked: every other blender?

Whenever I try to edit the material name or other settings coming from multiple workflows, Blender freezes up, sometimes this causes my whole screen to freeze up and I have to ssh into the system remotely and kill the blender process.

Exact steps for others to reproduce the error

  1. Start up Blender
  2. Click on splash screen to close it
  3. Click on the Material tab for the object
  4. Click in the Material name box
  5. Try to click anywhere else

Sometimes it just locks the blender process, sometimes it locks up my desktop. I've been having periodic freezes like this in most of the 2.80 nightly builds, but this is one of the first times it's been something simple and reproducable.

Details

Type
Bug

Event Timeline

Some details to add to this. It only happens when I am using Eevee. It doesn't happen when the render engine is set to Cycles.

from fresh open Blender linux RC2 work fine
OpenSUSE Tumbleweed, AMD FX8350 16G ram, GTX690 Nvidia 340.34

factory setting solve this issue?

can you upload a simple .blend file to reproduce this issue?

I tried resetting to factory defaults and that didn't change the issue. As far as uploading a blend file, all i could do is open blender and then save the default file. Do you want me to do that?

More info. On the host that has the issue, I'm using the nouveau display driver and 3 monitors.

I tried this test on another Linux system running Ubuntu 18.10 and it didn't have the freezup issue using the same steps above. That other system is using a GeForce GTX 1050 and the nvidia drivers. So I suppose it could be an issue with either Nouveau, 3 monitors or the GT 610 and/or nouveau drivers.

More testing. I found some old nightly builds of the 2.80 series from January and April and found some interesting results.

In the January 11th, 2019 build (blender-2.80-6439ed844e78-linux-glibc224-x86_64), I encounter the same issue that I do with RC2 using the steps above.

In the April 28th, 2019 build (blender-2.80-d2f1705b15be-linux-glibc224-x86_64), I DO NOT encounter the same issue. I'm able to modify some material settings and then go do other stuff at least for a little while. It eventually does freeze up, but it's not freezing consistently.

I tried running an strace on the RC2 blender process to see if that provided any clues as to the issue. It was showing all the syscalls running along until the freeze happened and then it just stopped until I killed the blender process. The strace unfortunately isn't very helpful. These are the last few calls I'm seeing before the process is killed.

recvmsg(3, {msg_namelen=0}, 0)          = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=3, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd=3, revents=POLLOUT}])
writev(3, [{iov_base="\22\0\10\0\2\0\340\2D\1\0\0005\1\0\0\10\0\4\0\7\0\0\0Blender\0"..., iov_len=64}, {iov_base=NULL, iov_len=0}, {iov_base="", iov_len=0}], 3) = 64
recvmsg(3, {msg_namelen=0}, 0)          = -1 EAGAIN (Resource temporarily unavailable)
recvmsg(3, {msg_namelen=0}, 0)          = -1 EAGAIN (Resource temporarily unavailable)
recvmsg(3, {msg_namelen=0}, 0)          = -1 EAGAIN (Resource temporarily unavailable)
futex(0x7ff05f965184, FUTEX_WAKE_PRIVATE, 2147483647) = 5
futex(0x7ff05f965130, FUTEX_WAKE_PRIVATE, 1) = 1
futex(0x7ff05f965180, FUTEX_WAKE_PRIVATE, 2147483647) = 2
futex(0x7ff05f965130, FUTEX_WAKE_PRIVATE, 1) = 1
futex(0x7ff05fa08f70, FUTEX_WAIT_PRIVATE, 0, NULL) = ?
+++ killed by SIGKILL +++
Killed

Just to make sure my video cards are handling 3D ok, I've been running Minecraft, Nexiuz, Neverputt, and of course Blender 2.79 works ok.

dark999 (dark999) added a comment.EditedJul 20 2019, 10:09 PM

Blender not support nouveau drivers only propritary Nvidia drivers
Please install last Nvidia GPU drivers from nvidia website
Can you update you report with SystemInfo file made with Edit > Save System Info item

thank you

Interesting, this is the first I've heard of the requirement to use nvidia drivers in Linux? Is that a new requirement for 2.80 and is it indicated somewhere?

I've uploaded my system info. Although on my system it was located in Help -> Save System Info

please upgrade your system with Nvidia proprietary drivers and confirm the problem

sorry, my mistake, it is Help menu item

Well thanks for your work on Blender, I appreciate it. Maybe you think just using the Nvidia driver under Linux is an easy choice to make, but by telling me to upgrade to Nvidia drivers you are basically telling me that I need to choose between using open source drivers under Linux and being able to use Blender in the future. From my point of view this isn't a very friendly open source stance for the Blender developers to be taking.

CUDA core are activable only with proprietary drivers, is not same with AMD GPU

I am not payed from Blender and/or i have any connection with them. I try to help here as volontary, all i write is IMO until was confirmed to an Blender's payed developer

IMO you lost an opportunity to use any kind of 3D software, but this is youe choice

PEACE

I use 3D software all the time, as I mentioned other 3D accelerated software works fine without issue, not sure what makes Blender 2.80 a different case.

dark999 (dark999) added a comment.EditedJul 21 2019, 7:42 PM

IMHO this report still invalid

Peace

Just to confirm you are correct, I changed my driver to nvidia-390 and now Blender works for me without issue. I broke my 3 screen desktop though as under the nouveau driver, I can use all 3 screens as one continuous desktop. Under the nvidia driver it splits it into 2 diferent desktops.

dark999 (dark999) closed this task as Invalid.Jul 21 2019, 11:29 PM
dark999 (dark999) claimed this task.

software not meet minimum blender requirement to report bug

Addison Miller (seaside98) reopened this task as Open.
Addison Miller (seaside98) removed dark999 (dark999) as the assignee of this task.

It looks like Cycles isn’t supported by the nouveau drivers, but I don’t see why the rest of blender shouldn’t run properly. This issue should be left open until a developer decides whether it is an issue that should be fixed or that they don’t support these drivers.

IMO It is not so
Before proprietary drivers installation, you had use a software OpenCL emulation from your CPU, you never had used GPU hardware acceleration when it was needed.
Blender Eevee needed hardware GPU acceleration to work (realtime is too expensive to CPU) or you can have many issues (as you've seen)
Cycles is designed to work with CPU or to be accelerated by CUDA (nvidia GPU) or OpenCL (AMD, Intel GPU) hardware, Eevee not

to properly configure yours GPUs with Nvidia drivers, you can use /usb/bin/nvidia-setting as root, this help a lot to configure multimonitor as split or mirror or what you want

FOSS is nice but sometimes the Others don't release their software as an open source license compatible with it, if you want to use it better you don't have many choices, you have to use a software outside of FOSS

I've been using GNU-Linux for the past 25 years and i tryed to use it where i had work, so I understand you

PEACE

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

Blender 2.80 currently only fully works with the NVIDIA drivers, not Nouveau.

While we would prefer it to work with everything, we don't currently have the time or resources to investigate and work around issues in the Nouveau driver on our side.