Page MenuHome

Poor Eevee performance on 2018 Macbook PRO
Open, Needs Triage by DeveloperPublic

Description

Even on simple scenes, the viewport performance in Look Dev or Rendered view is very low, around 3fps for the attached scene.

My specs are:

Macbook Pro 15" 2018
2,2 GHz Intel Core i7
16 GB Ram
Radeon Pro 555X 4GB

macOS 10.14.5 (18F203)

Blender 2.80 RC 2

See also:

https://blenderartists.org/t/very-bad-eevee-viewport-performance-on-macbook-pro-2018/1154917

Details

Type
Bug

Event Timeline

Bart Veldhuizen (bart) renamed this task from Poor performance on 2018 Macbook PRO to Poor Eevee performance on 2018 Macbook PRO .Jul 20 2019, 12:49 PM
Bart Veldhuizen (bart) added a project: Eevee.

I can confirm this bug on OSX 10.12.6

is a cleaned up version exposing the problem. If I disconnect any diffuse or principal bsdf the performance is ok again.

I do not see any errors running with debug option besides the output below - but I do not think it is related.

System Information
Operating system: Darwin-16.7.0-x86_64-i386-64bit 64 Bits
Graphics card: AMD Radeon R9 M370X OpenGL Engine ATI Technologies Inc. 4.1 ATI-1.51.8

Blender Version
version: 2.81 (sub 8), branch: master, commit date: 2019-09-07 16:22, hash: rBabeab4fcad66

debug output:

GPUShaderInterface: Warning: Uniform 'attr' not found!
GPUShaderInterface: Warning: Uniform 'hairPointBuffer' not found!
GPUShaderInterface: Warning: Uniform 'hairUVBuffer' not found!
GPUShaderInterface: Warning: Uniform 'hairColBuffer' not found!
GPUShaderInterface: Warning: Uniform 'colorBuffer' not found!
GPUShaderInterface: Warning: Uniform 'depthBuffer' not found!
GPUShaderInterface: Warning: Uniform 'minzBuffer' not found!
GPUShaderInterface: Warning: Uniform 'planarDepth' not found!
GPUShaderInterface: Warning: Uniform 'texHammersley' not found!
GPUShaderInterface: Warning: Uniform 'texJitter' not found!
GPUShaderInterface: Warning: Uniform 'inScattering' not found!
GPUShaderInterface: Warning: Uniform 'inTransmittance' not found!