Page MenuHome

Visibility problems in Edit mode - Solid view
Open, Confirmed, MediumPublic

Description

System Information
Operating system: Linux-5.0.1-050001-generic-x86_64-with-debian-buster-sid 64 Bits
Graphics card: GeForce GTX 960/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 430.26

Blender Version
Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-07-18 14:52, hash: rB38d4483c6a51
Worked: (optional)

Short description of error
In this first file:


It is really difficult to distinguish that the front vertex is selected (that marked under the blue circle). In the other vertices it is also difficult to distinguish which of the vertices are in front or which are behind.

In this other file:


On the left, in Vertex select mode the edges coinciding with the blue Z and red X axis are almost invisible. On the right, in that view two of the vertices selected in front appear as not selected. The same in Edge select mode.

Details

Type
Bug

Event Timeline

YAFU (YAFU) updated the task description. (Show Details)
YAFU (YAFU) added a comment.EditedJul 23 2019, 1:19 PM

By the way, I think it's not good that vertices in front are less prominent and less visible than those at the back in those views in Ortho view. This really makes work difficult. This is working in the opposite way to what it did in 2.79. Not sure if this is by intentional design or a bug.

Edit:
And apparently in Blender 2.8 the behavior seems to depend on Viewpoint, Front is different to Back and Top is different to Botton. I expected Top view to behave like Front, but apparently it is reversed there.
Anyway I clarify that in the original post of the report, when I say "Front", I refer to the side closest to the user, regardless of which Viewpoint we are. In 2.79 it seems that this is not viewpoint dependent, and always vertices closer to the user are always more prominent than the farthest vertices, and I think that is how it should work.

Sebastian Parborg (zeddb) closed this task as Archived.Jul 24 2019, 3:55 PM
Sebastian Parborg (zeddb) claimed this task.

This is a limitation of the new viewport render engine. It might be possible to fix, but it is not thing that we will actively look into.

YAFU (YAFU) added a comment.EditedJul 24 2019, 4:30 PM

Hi Sebastian.
I understand that my report may not have been clear because I started with issues that can be considered as design/limitations. Just in case to make it clear that you saw the last case, the verices closest to the user in Front viewpoint are selected, but they look unselected

This gets even worse if you switch to Back viewpoint and you want to choose one of the three vertices closest to the user in that view.

Otherwise, I hope that view in Ortho view for modelers will have more attention in future releases.
Thank you.

Sebastian Parborg (zeddb) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.

Fine, you win ;)
(This makes otho view quite useless so it should be fixed)