Page MenuHome

metadata "Include Labels" checkbox doesn't work when "Use Strip Metadata" is checked
Open, Confirmed, MediumPublic

Description

System Information
Operating system: Windows 7
Graphics card: NVIDIA Gtx780

Blender Version
Broken: 2.8 RC3

Short description of error
Metadata "Include Labels" checkbox doesn't work well when "Use Strip Metadata" is checked.

Exact steps for others to reproduce the error
Open blender. In Metadatas settings, check "Burn to image". Check "Use Strip Metadata". Uncheck "Include Labels". Do a render. Labels are visible.
Thank you!


Edit: I shoudn't enable "use strip metadata" if there is not a strip in the sequencer, but blender shoudn't override "include labels" if the user does, no ? Thank you very much.

Edit2: When you add an image in the sequencer that has metadata inside, when you enable "use strip metadata", blender doesn't use these infos. (you can check they exist in UV Image Editor with "show metadata" enabled)

Details

Type
Bug

Event Timeline

maybe Burn Into Image work as expected? it add metadata over image.
if you want include metadata on image but not overprinted on it, you must uncheck Burn Into Image and activate in render viewer View > Show Metadata

I confirm issue on ubuntu 64bits with master 62338abde433
Labels are always included.

IMO this is a designed feature not bug, i can confirm that work as expected IMHO

@ronan ducluzeau (zeauro) you read what i wrote? it work as i explain or metadata still overprinted?

as i already tell

@dark999 (dark999) : You don't seem to understand the issue here, I think. He wants to burn into the image. The issue here is the behavior of "Include Labels" which should alter how things are burnt into the image. With "Include Labels" ON, you expect strings like "Camera Camera.001", "Scene Scene". However with "Include Labels" OFF, it should skip the 'label' part and just burn "Camera.001", "Scene" and so on.

here all working as expected as already tell

Ghislain (Cremuss22) added a comment.EditedJul 26 2019, 6:03 PM

@dark999 (dark999) please read what people are saying.

By the way I can confirm the bug on Blender 2.8 RC2 as well. It was working as expected in 2.79 as shown here


Thanks

dark999 (dark999) added a comment.EditedJul 26 2019, 6:18 PM

@Ghislain (Cremuss22) in your pics right side i not see label, only metadata as expected

Ghislain (Cremuss22) added a comment.EditedJul 26 2019, 6:23 PM

@dark999 (dark999) not sure if you're trolling or not... but, again, please read what people write. You'd have understand this is a picture from 2.79 showing the expected and working behavior. This is bugged in 2.8. Thank you

@Ghislain (Cremuss22) in my blender RC3 i have same result as your picture of 2.79, you troll me? check my screecap

@dark999 (dark999) yes but as stated in the bug description, the issue appears if you toggle on "Use Strip Metadata" which bugs the behavior of "Include Labels" (and it didn't in 2.79)

@dark999 (dark999) It could be this doesn't affect Linux...

I can confirm the issue on windows with 2.80RC3.

dono dono (dono) renamed this task from metadata "Include Labels" checkbox doesn't work to metadata "Include Labels" checkbox doesn't work well when "Use Strip Metada" is checked.
dono dono (dono) renamed this task from metadata "Include Labels" checkbox doesn't work well when "Use Strip Metada" is checked to metadata "Include Labels" checkbox doesn't work when "Use Strip Metada" is checked.
dono dono (dono) renamed this task from metadata "Include Labels" checkbox doesn't work when "Use Strip Metada" is checked to metadata "Include Labels" checkbox doesn't work when "Use Strip Metadata" is checked.Jul 26 2019, 6:38 PM
This comment was removed by Robert Guetzkow (rjg).

what are Strip Metadata in this case?
please, follow this step
disable Use strip metadata,
disable Burn Into Image,
disable Include Labels,
render image,
in Blender Render window or Image Editor we can see an cristal clear render image,
enable View > Show Metadata
two black rectangles are shown above and below the rendered image with text inside, all text you see are Strip Metadata. For example for camera, Strip Metadata stored inside image is Camera: Camera . YES Label: plus metadata

Strip Metadata include labels

if you want overprint Strip Metadata in renderd image Labels are part of Strip Metadata

i hope all this is comprensible and clear, Blender 2.80RC3 work same as 2.79b, same results with same setting

PEACE

My mistake, I thought the behavior was different in 2.79 but I mistook Strip Metadata setting with Seq. Strip :(

Still, I understand the label is part of the metadata and thus showing when using Strip Metadata but then it just seems to be conflicting with "Include Labels".

I'd suggest maybe graying out "Include Labels" if "Strip Metadata" is toggled on because it can be confusing, or mentionning this behavior in "Strip Metadata" tooltip :)
Thanks for the help.

Ok, I understand better now. The option "Burn into image" is not the problem.

The problem is that I shoudn't enable the "Use Strip Metadata" button if there is not a strip in the sequencer.

But if I do, blender could tell "ok, there is not a strip in the sequencer, so I don't override the "include labels" button".

Thanks for explanation.

Ghislain (Cremuss22) added a comment.EditedJul 26 2019, 9:08 PM

indeed, that is the real explanation here. I suspect it has something to do this patch... maybe? with https://developer.blender.org/rB175e8fdc1e2e76bd1287f1aa93db4aa4cc44d3f9

Using "Strip Metadata" let you choose per scene, in the sequencer, what metadata to show, and "Include Labels" works fine if you have multiple scenes. However, with only a single scene, "Strip Metadata" will override "Include Labels" for no reason

Screenshot showing both options working fine together when rendering from the sequencer using multiple scenes

EDIT: @dono dono (dono) found out actually that adding anything to the sequencer resolves the bug. "Strip Metadata" on with "Include Labels" off works fine if any strip is added to the sequencer

dono dono (dono) closed this task as Resolved.Jul 26 2019, 9:42 PM
dono dono (dono) reopened this task as Open.Jul 26 2019, 9:47 PM
Jacques Lucke (JacquesLucke) triaged this task as Confirmed, Medium priority.

I'm not sure what is the correct solution (because I never used this feature), but clearly there is a small UI issue here. So I confirm this. Maybe @William Reynish (billreynish) knows what is the correct solution or knows who should know.

There seems to be some sort of conflict between Use Strip Metadata and Include Labels. Unless I misunderstand, this is not so much a UI issue, but something deeper.