Page MenuHome

Boolean modifier changes its operation intermittently
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 430.86

Blender Version
Broken: version: 2.80 (sub 75), branch: master, commit date: 2019-07-24 14:22, hash: rB507ffee6e1f4
Worked: (optional)

Short description of error
I'm doing boolean operations, where I want to use UNION to weld the parts together. It works fine, but after a few operations, UNION stops working.
I have found out, that if I then swith it to DIFFERENCE, it works exactly as UNION.
Next time I use UNION it works fine again.

Exact steps for others to reproduce the error
I have not been able to determine the exact sequence, but even if I restart Blender RC3 from scratch with my file it still does it within the first 5 or six boolean operations.

I'm pretty sure it also did this in RC1 and RC2, but I used to drop what I was doing and move on to something else.
But for RC3 I did a little digging and came up with switching to DIFFERENCE, which took over the role of UNION.
I only noticed because the outline changed to what I would expect with UNION.

Details

Type
Bug

Event Timeline

Please wait to obtain an evidence before posting a report.

You cannot reproduce it. We cannot reproduce it.
Under these circumstances, adding a report on a technical site where influence is less important than community sites with beautiful pictures does not help.
Try support forums to warn as many users as possible.
When more people are aware, more people are testing : then, probability that someone can find sequence responsible of problem becomes higher.

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

Yep, we need a proper way to reproduce the issue...

Sybren A. Stüvel (sybren) closed this task as Archived.
Sybren A. Stüvel (sybren) claimed this task.

Since last asking for information it has been 7 or more days, due to the policy of our bug tracker we will have to archive the report until the requested information is given.