Page MenuHome

GPU is still not recognized on Macs (Radeon Pro) ... "Cycles will render on the CPU" (2.80rc3)
Closed, ArchivedPublic

Description

...while it was working on the 2.79 and older. Is it for all Radeon cards, even 2019 (580) ? Do you want to lose all your Mac users? Are they a so insignifiant part?
Bests

System Information
Operating system: MacOs 10.14.5
Graphics card: Radeon Pro 575

Blender Version
Broken: 2.80rc3
Worked: 2.79b

Short description of error

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).

Details

Type
Bug

Event Timeline

Apple has deprecated OpenCL for macOS 10.14 and future releases. Since macOS won't have any updates for the OpenCL compiler and therefore no bug fixes, Blender 2.8 will no longer use OpenCL on macOS. Since this was an intentional decision by the Blender developers to remove OpenCL it is not considered a bug, which is why we close this report.

Below you find and excerpt from the Blender mailing list where Sergey Sharybin explains this decision.

Cycles: OpenCL on macOS has been disabled
There was a growing payload of bugs in Cycles related on OpenCL on macOS
platform, and those issues were caused by a compiler bug, which we have no
control over.
Surely, it is sometimes possible to work compiler bugs around from a
source, but we are facing some of the issues which are not solvable in this
way. Also, such solutions are usually short-living,. since adding more
features are often kicking compiler to provide buggy binary again.
In this case compiler will not get fixed since Apple decided to discontinue
OpenCL on its platform.
So the decision was made to drop support of OpenCL, keep official features
of Blender stable and predictable, and focus on things we have control over.
P.S. Older Blender releases are always available. Surely, this sounds like
using an ancient software without neat features. But we can't push Cycles
OpenCL on macOS measurably beyond that anyway.

https://lists.blender.org/pipermail/bf-committers/2018-December/049695.html

Sergey Sharybin (sergey) closed this task as Archived.
Sergey Sharybin (sergey) claimed this task.

OpenCL drivers on macOS are on an abandoned state. They have known bugs which will never be fixed in the driver (because Apple decided to go their own Metal way) and which can not be worked around from Blender side.

This is documented in 2.80 release notes: https://wiki.blender.org/wiki/Reference/Release_Notes/2.80/Cycles#GPU_rendering

Thanks for the report, but it's nothing we can do.

Please don't blame this on the hard working developers. They value all users and try their best to support all platforms. If you want to be mad at someone, that would be Apple.

Hmmm, ok. Thank you for your responses. So sad and strange! Do you have statistics of the % of Blender's users on Mac? Is there a Blender Mac Community? Because it deserves a group action on Apple, to let them know that they may lose a lot of clients!

Other thing is that it's not easy to understand if Eevee is using a lot the graphic card power or not? It seems to work very fine even without it, but I don't create very complex projects on it right now.