Page MenuHome

Smooth profile not behaving as expected with loop cut
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce GTX 1050 Ti with Max-Q Design/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 431.70

Blender Version
Broken: version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: rBf6cb5f54494e
Worked: (optional)

Short description of error
When using the loop cut operator with Smoothness set to .5, one would expect the smoothness profile selected to be the resulting shape- this is not the case. The "sphere" profile creates a wobbly "S" shape, for example. All of the profiles seem to exhibit this type of behavior.

Exact steps for others to reproduce the error
See attached video{F7640585}

Details

Type
Bug

Related Objects

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Waiting for Developer to Reproduce priority.

Pretty sure this would not be considered a bug, but there is a clear difference between Loop Cut and doing the comparable Move operation with Proportional Editing, see:
Havent checked code here, but the reason might be that the algorithm doesnt really know which "side" / loop to pick as the falloff root [pure speculation, should read code here...]


So for cases like these, maybe this should be added as TODO / Papercut in T63731: Modeling Module?

@Campbell Barton (campbellbarton) : what do you think?

Campbell Barton (campbellbarton) closed this task as Archived.EditedWed, Aug 7, 8:50 PM

The smoothing shown in this example would need to treat faces differently from edge-loops (or somehow choose different smoothing methods).

The current smoothing method is intended to smooth between tube end-points that don't meet, eg: https://docs.blender.org/manual/en/latest/_images/modeling_meshes_editing_edges_bridge-advanced-after.png

What's suggested here is quite a different use-case and not an error in the current smoothing logic, closing.