Page MenuHome

Instant Crash Adding Displacement Node to Material Output Node
Closed, ResolvedPublic

Description

System Information
Operating system: WIndows 7, 64 bit
Graphics card: Intel(R) HD Graphics 4600, AMD Radeon(TM) HD8970M

Blender Version
Broken: V2.80
Worked: (optional)

Instant crash when Adding Displacement Node to Material Output Node

Exact steps for others to reproduce the error

  1. Start Blender
  2. Load Factory Default settings
  3. Select default cube
  4. Select Shading workspace
  5. Add a Displacement node
  6. Connect Displacement node to Material Output nod (Diisplacement slot)

Blender crashes. Blender also crashes if I set renderer to Cycles. Blender also crashes if I connect Image node Color slot to Principled Shader node Base Color slot.

Based on the default startup


Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) triaged this task as Needs Information from User priority.

Please ensure you have installed the latest graphics drivers for the Intel HD 4600:
https://downloadcenter.intel.com/download/28798/Intel-Graphics-Driver-for-Windows-7-8-1-15-36-?product=81496

You can also check if the issue is solved in the latest daily build: https://builder.blender.org/download/

I can't install the latest graphics driver - I get an error message that says "The driver being installed is not validated for this computer. Please obtain the appropriate driver from the computer manufacturer." The driver recommended by Dell is ancient - Version 10.18.10.3496 from 2014, which is even older than the one I have installed (10.18.14.4414, 2016). I guess it's time for me to get a new computer. :)

Managed to get my graphics driver updated (from 10.18.14.4414 to 10.18.14.5067) by installing the drivers manually and now the issue no longer occurs. Thanks for the help!

Brecht Van Lommel (brecht) claimed this task.