Page MenuHome

OIDN: RAM increases proportionally with each Denoise node used
Closed, ResolvedPublic

Description

System Information
Operating system: Linux-5.0.1-050001-generic-x86_64-with-debian-buster-sid 64 Bits
Graphics card: GeForce GTX 960/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 430.40

Blender Version
Broken: version: 2.81 (sub 2), branch: master, commit date: 2019-08-20 18:26, hash: rBb6b01c48fa41
Worked: (optional)

Hello
Apparently RAM increases proportionally with each Denoise node used in compositor:


Denoise RAM_1.blend - 2.2GiB
Denoise RAM_2.blend - 13GiB

We are not sure about whether this is an expected behavior or a bug:
https://blenderartists.org/t/big-denoise-test-intel-open-image-denoise-vs-others/1175114/46

Details

Type
Bug

Event Timeline

The compositor is running separate threads for independent nodes. In most constellations, that means that all denoising nodes run at the same time.

Since OIDN internally is multithreaded across all CPU cores, should we wrap it in a mutex to ensure only one denoising kernel runs at a time?

Mutex sounds like a good solution to me.

Stefan Werner (swerner) closed this task as Resolved.Tue, Aug 27, 11:07 AM