Page MenuHome

DXF not importing solids
Closed, InvalidPublic

Description

System Information
Operating system: Windows 10 (AMD Rizen 7-1700 Eight-core processor 3.00GHZ 16 gb ram
Graphics card: AMD Radeo RX580 8192 MB

Blender Version
Broken: 2.8

Short description of error

Only accept Autocad dxf 2d entities (not solid, neither meshes or surfaces)

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.

Looking at https://cad4arch.com/dxf_importer/index.htm, this might be the case for DXF > r12 regarding 3DSOLID.
(the three dots represents what is possible with the DXF importer included in blender, the other ones are supported by the Personal Edition offered on that site)

DXF>r12 objects:
lll lll   lll lll  - ELLIPSE
lll lll   lll lll  - LWPOLYLINE (LightWeight Polyline)
lll lll   ... lll  - SPLINE
... lll   ... lll  - REGION (ACIS/SAT) (via external converter)
... lll   ... lll  - 3DSOLID (ACIS/SAT) (via external converter)

Not sure which version of Autocad you are using or which version of DXF that is exporting, so to be really sure what is going on, we would need an example .DXF to have a look...

Philipp Oeser (lichtwerk) renamed this task from DXF to DXF not importing solids.Tue, Aug 27, 2:25 PM
Bastien Montagne (mont29) closed this task as Invalid.
Bastien Montagne (mont29) claimed this task.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.