Page MenuHome

Camera Gizmo not displaying properly
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-7-6.1.7601-SP1 64 Bits
Graphics card: Quadro 2000D/PCIe/SSE2 NVIDIA Corporation 4.3.0

Blender Version
Broken: version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: rBf6cb5f54494e
Worked: (optional)

Short description of error
My camera Gizmo is not displaying as it does in the tutorials. It is just a dot and yellow rectangle, not the cone shape and up arrow.
Leander on Stack Exchange took me through some actions, re-loading factory defaults, checking overlay extras etc but nothing worked... use this link to see screen grabs and actions: https://blender.stackexchange.com/questions/149945/camera-widget-display#149954

Creating a new scene or closing down and re-starting Blender has no impact

Exact steps for others to reproduce the error
No steps - my camera gizmo does not display properly from startup

<img src="https://blend-exchange.giantcowfilms.com/embedImage.png?bid=6470" />

Details

Type
Bug

Event Timeline

Abid Maqbool (cto.abid) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Aug 27 2019, 6:02 PM

@Graham (penga) If you can please try in .zip (portable) version of Blender:


If this not solves your prob, then i think, last think you should try at least updates you graphics drivers (form supports site)

@Abid Maqbool (cto.abid)

Tried the portable version of blender - no difference.

My Nvidia Quadro 2000D control panel has been searching for driver updates with no luck and I am nervous about selecting from the Nvidia site as I have other editing software on the machine (Avid media Compser) that might be affected.

Without knowing if up-to-date drivers solve the problem I think there is not much we can do here...

@Graham (penga) Can you please! Confirms too in daily build Blender 2.81?
https://builder.blender.org/download/

@Graham (penga) enable this and you will see camera gizmo

feel free to confirm this

thank you
[EDIT] i have same result as @Graham (penga) with disabled extra overlay and camera selected

@dark999 (dark999) : that might be the reason actually, thx for checking...

Thanks - that was suggested by Leander on StackExchange yesterday. Extras are enabled but camera still displays as your second image above.

@Graham (penga) try in 2.81 too?
Also please sends the screen-shot whit Camera (Prob) and Overlay menu open (where extras exists). like the one shows below:

Tried 2.81.3 - same problem. Screengrabs of both versions above.

Hi Abid,

My IT guy just updated the video card drivers - I can now see the camera gizmo.

There were a few other wierd things happening before the driver update. Shadows were not showing (in Eevee mode with Viewport Shading in Rendered mode). Also If I selected the Material option in the properties panel on the right hand side, Blender would just close down. With the driver update, this is now fixed.

Thanks for your help.

Philipp Oeser (lichtwerk) closed this task as Resolved.Aug 29 2019, 3:40 PM
Philipp Oeser (lichtwerk) claimed this task.

Thx for getting back, closing then