Page MenuHome

Brick texture in Eeeve - crash when changing parameters
Open, Needs Triage by DeveloperPublic

Description

System Information
Operating system: Windows-10-10.0.17763 64 Bits
Graphics card: GeForce GTX 750 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 436.15

Blender Version
Broken: version: 2.81 (sub 3), branch: master, commit date: 2019-08-28 03:44, hash: rBf88022b96f3a

Short description of error
Changing parameters of brick texture in Eevee will often crash Blender (but not in Cycles).

Exact steps for others to reproduce the error

  • Open file.
  • First switch to "rendered" mode.
  • Before doing anything select one face in edit mode.
  • Now change "Squash" value in node to for example 10.

It will either crash or turn completely black. If it turns black you can switch to object mode and back.
It doesn't crash in debug mode, perhaps because everything is slower. It does however turn black.

Details

Type
Bug

Event Timeline

Hum! In mine case no crash at all, however, it's becomes black & have to switch to Object Mode

here i have a crash on linux Blender 2.80 f6cb5f54494e (Stable) AMD FX8350, 16GB DDR3, GTX690 2+2 GB VRam- Nvidia drivers 435.17, Factory Setting applied, LoadUI and Trusted Source disabled in file browser, to note that UVMap node had nothing selected

all work fine and no crash if i select UVMap in UVMap node

I can't reproduce this with a debug build, but I get run-to-run behaviour differences following the above steps with the release build. Sometimes the program segfaults, other times the object turns black until I switch to object mode, other times it turns black then quickly redraws correctly. Attached a crash log for a segfaulting release build.

Blender: version: 2.81 (sub 4), branch: master, commit date: 2019-08-28 18:52, hash: rB34ed58dcaffd, type: Release
System: Ubuntu 19.04, GeForce GTX 960/PCIe/SSE2, 4.5.0 NVIDIA 418.56

I tested with newer drivers: 440.97 and newer build: 2019-10-27 13:40, hash: rB9b6aa740be31 and it seems to be fixed. Can anyone confirm?

windows 10, radeon HD , legacy driver. blender 2.82 last build
no crash here