Page MenuHome

Delete files
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce GTX 950M/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 411.63

Blender Version
Broken: version: 2.81 (sub 4), branch: master, commit date: 2019-09-01 20:47, hash: rB928e0258fea7
Worked: (optional)

Short description of error
Can't delete files in file browser. This work in 2.79, but in 2.81 not work

Details

Type
Bug

Event Timeline

This feature was (temporarily) removed with commit rB64acb70e7f0f92b667cfaa006c94b5b8f3b79c27 because the file browser permanently deleted files instead of just moving them to the recycling bin. Since that behavior is destructive and unexpected, the feature is removed until the patch for moving files to trash on all supported operating systems is approved and commited (D4585).

Robert Guetzkow (rjg) closed this task as Archived.Sep 3 2019, 1:40 PM
Robert Guetzkow (rjg) claimed this task.

I'm closing this task since it's not a bug, but a feature that is currently being worked on.

Why u delete option and don't ask users, or dont' make it optional?? I need this option!

@CHET (cheteron) because users could accidentally delete their files permanently they way it used to work in 2.79. The developers considered this to be dangerous and a bigger downside compared to the inconvenience of having to open the Windows Explorer to delete files for now. The feature will likely return in the 2.81 or 2.82 release depending on whether the changes are completed before 2.81 is released.

@CHET (cheteron) This feature is now back in Blender with commit https://developer.blender.org/rB8825250f5a85c0c16e74ed144dd2b4a7d752042f. You may have to wait for the release of Blender 2.81, use one of the experimental builds or build it yourself.