Page MenuHome

Subdivision surface modifier doesn't affect objects
Closed, ResolvedPublic

Description

System Information
Operating system: Linux-5.0.0-21-generic-x86_64-with-Ubuntu-19.04-disco 64 Bits
Graphics card: GeForce GTX 1060 6GB/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 430.34

Blender Version
Broken: version: 2.81 (sub 5), branch: master, commit date: 2019-09-02 20:51, hash: rBd74cc6c08c42
Worked: Blender 2.80 official release

Short description of error
Subdivision surface modifier doesn't affect objects.
Nothing changes when adding it, and I can't apply the modifier to the object neither.

Exact steps for others to reproduce the error
Simply add a cube and apply a Subdivision surface modifier to it.

Here is the a simple blend file:


Here is a view of the problem:

It also doesn't affect other meshes like monkey, spheres, ...

Thanks!

Details

Type
Bug

Event Timeline

I can't reproduce it on the same blender version

If you built Blender yourself, check in build_linux/CMakeCache.txt you have WITH_OPENSUBDIV:BOOL=ON. If not, set it and re-build.

If you downloaded Blender from https://builder.blender.org/download/ then disregard this comment.

I can't reproduce it on macOS neither. Could this be OS related ?

Tested on the same version from
Operating system: Darwin-18.7.0-x86_64-i386-64bit 64 Bits
Graphics card: Intel(R) Iris(TM) Graphics 6100 Intel Inc. 4.1 INTEL-12.10.12

The WITH_OPENSUBDIV:BOOL was set to OFF. I set it to ON, and now it seems to work on linux.
Do you have any clue why this parameter was off ? (So that I can avoid having this kind of problem in the future)

Thanks!

I've made it so a warning is displayed in the modifier when Blender is compiled without OpenSubdiv.

The reason why it is disabled in the first place is due to default CMake configuration, which tries to minimize compilation errors caused by missing libraries. This is more a historical question, with install_deps.sh and make deps in place we should really make default configuration match the release settings.

Not sure if it's something for the bug tracker though.

Damien Korber (BlinkingLemon) closed this task as Resolved.EditedTue, Sep 3, 12:31 PM

Ok, thanks for your explainations. I think this task can be closed then.