Page MenuHome

Quick Smoke is Broken
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.17134 64 Bits
Graphics card: GeForce GTX 1080/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 430.86

Blender Version
Broken: version: 2.81 (sub 6), branch: master, commit date: 2019-09-04 14:30, hash: rB45d4c925799e
Worked: (optional) 2.80

Short description of error
Quick Smoke is broken in the latest build.

Exact steps for others to reproduce the error
Select the default cube
Go to the Object menu and press Quick Effects > Quick Smoke
A domain object will be created and the smoke effect will be applied to the cube
Press play on the timeline
No smoke will appear to emerge from the cube.
Repeat the same steps in 2.80 and you'll get smoke coming out of the cube.

Details

Type
Bug

Event Timeline

Today's Linux buildbot version seems to work OK.
commit date: 2019-09-04 09:55,
hash: 4d995527a9a1,
build date: 2019-09-04, 13:11:21

Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Sep 5 2019, 10:04 AM

Also cannot reproduce here.

Please check:

  • latest buildbot build
  • Factory Settings
  • is this happening in all viewport shading modes?

I've isolated the problem. It's the AnimAll addon. If AnimAll is enabled, QuickSmoke will not be visible in the viewport.

Stephen Swaney (stiv) closed this task as Resolved.Sep 5 2019, 6:43 PM
Stephen Swaney (stiv) claimed this task.

Interesting. And good detective work!
Closing as Resolved.

I'm curious as to what AnimAll addon is doing to cause conflict.

I think this is due to AnimAll adding a data refresh handler, see rBA0a6d3d725f0b

Sorry about that, I introduced the bug. It is alleviated by rBAc3348263dc26, but it will still happen if the smoke mesh has animation data.

that could be a reason that the refresh was not used?

Well, if the smoke simulation is broken, there are probably other areas affected as well… For instance, I just tested with a particle system, and the particles stick to the surface instead of falling down. It is fixed by rBAc3348263dc26 as well, though.