Page MenuHome

Error popups spawned from new FileBrowser are "swallowed" (e.g. Addon import/export errors)
Closed, ResolvedPublic

Description

System Information
Operating system: Linux-5.2.8-200.fc30.x86_64-x86_64-with-fedora-30-Thirty 64 Bits
Graphics card: GeForce GTX 970M/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 430.26

Blender Version
Broken: version: 2.81 (sub 8), rBd813cc706d79daf84100f9090db5f11c917e50c0
Worked: version: 2.81 (sub 8), rB6fc6f2504dfdae50c8184185222350052be0775c

Short description of error
Error popups spawned from new FileBrowser are "swallowed" (e.g. Addon import/export errors) and cannot be seen in the UI anymore.
They are still thrown to the console, but users will be unaware of these errors which will make bugreports a pain and is generally a bad user experience.

Exact steps for others to reproduce the error

  • force an error in an Addon, e.g. by doing

1
2
3diff --git a/io_scene_obj/__init__.py b/io_scene_obj/__init__.py
4index bddf758b..434a0cc9 100644
5--- a/io_scene_obj/__init__.py
6+++ b/io_scene_obj/__init__.py
7@@ -446,7 +446,7 @@ class ExportOBJ(bpy.types.Operator, ExportHelper):
8 def execute(self, context):
9 from . import export_obj
10
11- from mathutils import Matrix
12+ from mathutils import DecentralizedCommunication
13 keywords = self.as_keywords(ignore=("axis_forward",
14 "axis_up",
15 "global_scale",

  • with the above, from the default scene, do File > Export > Wavefront (.obj)
  • you should get an error, but... nothing
  • error is still thrown to the console, but we need this in the UI as well!
Traceback (most recent call last):
File "/build_linux/bin/2.81/scripts/addons/io_scene_obj/__init__.py", line 449, in execute
    from mathutils import DecentralizedCommunication
ImportError: cannot import name 'DecentralizedCommunication' from 'mathutils' (unknown location)

Not quite sure why rBd813cc706d79 broke this, needs more checking...

Event Timeline

Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Confirmed, High.Sep 6 2019, 11:41 AM
Philipp Oeser (lichtwerk) created this task.

I dare setting this to High...

CC @William Reynish (billreynish)
CC @Julian Eisel (Severin)

Since rB4c20c53b8980 (thx @Julian Eisel (Severin)! ) only partially fixes, will reopen...

Julian Eisel (Severin) lowered the priority of this task from Confirmed, High to Confirmed, Medium.Sep 6 2019, 1:14 PM

Setting to medium though since the error is reported clearly now, it's just missing the additional popup report.
Got an appointment now, will check as soon as I'm back.

Julian Eisel (Severin) closed this task as Resolved.Sep 6 2019, 4:58 PM

Committed second part rB83a7d98a32. Should be all fine now.