Page MenuHome

Menus don't open again once collapsed despite having focus.
Closed, InvalidPublic

Description

System Information
Operating system: Darwin-18.6.0-x86_64-i386-64bit 64 Bits
Graphics card: Intel(R) HD Graphics 6000 Intel Inc. 4.1 INTEL-12.9.22

Blender Version
Broken: version: 2.81 (sub 8), branch: tbtask, commit date: 2019-09-08 13:32, hash: rBc3be14e15196

Short description of error
Slight incoherence between behaviour in rest of macOS and Blender. Menus don't expand again if mouse goes out of the list and hovers on the menu buttons after returning.

To see expected behaviour:

  • Open any macOS application, open any menu, say File.
  • Take the mouse pointer outside the menu list.
  • Bring the pointer over a different menu say Help. It would expand.

However, in blender, Help menu would be highlighted in blue but will not expand.

Exact steps for others to reproduce the error

  • Open an empty workspace.
  • Click on File menu, and take the pointer outside the menu list, say on timeline, but don't click anywhere. You'll notice that File menu is collapsed, but the button is blue.
  • Hover over the menu buttons now, say Help. They become blue, but don't open. You must click to open them. In rest of the Mac applications, they do open.

Trivia
The difference is also that Mac menus stay open even if we take pointer out of the list, while Blender closes them.

Details

Type
Bug

Event Timeline

Campbell Barton (campbellbarton) closed this task as Invalid.

Blender doesn't attempt to follow widget behavior of the underlying operating system.

UI changes can be discussed here: https://devtalk.blender.org/t/blender-ui-paper-cuts/2596

Closing, since this is a request and the issue tracker only accepts bug reports from users see: https://wiki.blender.org/wiki/Reference/Not_a_bug

Ankit Meel (ankitm) added a comment.EditedMon, Sep 9, 6:39 PM

@Campbell Barton (campbellbarton) but the buttons are blue which means they should open the menus even if there is a difference in the behaviour. Or the focus should return to where it was.